when i click the edit button in the grid view it row extends vigorously.

4 posts, 0 answers
  1. Ranjit
    Ranjit avatar
    3 posts
    Member since:
    Apr 2013

    Posted 19 Apr 2013 Link to this post

    When I click the edit button in the grid view the row extends vigorously, which overlaps my other control horizontally. I want to fix the size of the grid row same as the non editable mode when i will be in editable mode.
  2. Dimo
    Admin
    Dimo avatar
    8446 posts

    Posted 22 Apr 2013 Link to this post

    (thread moved from the ListView forum to the Grid forum)

    Hello Ranjit,

    Tables rows always expand vertically, so that all contents inside fits. The only way to supress this is to wrap the cell content in containers with a fixed height and an overflow style. In other words, use an Editor template. Please refer to the offline MVC Grid demos, which show how to do that. Another option is to use a popup edit form.

    On a side note, I am not aware of your scenario and it is not clear why the layout change occurs in your case.

    Regards,
    Dimo
    the Telerik team
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
  3. Ranjit
    Ranjit avatar
    3 posts
    Member since:
    Apr 2013

    Posted 22 Apr 2013 Link to this post

    Hi Dimo,
                   Thanks for your reply. Actually I faced one trouble in Gridview that when I click the edit button that row extends horizontally, which overlaps the right side content of that page. so we decided to create a ajax form with partial view concept for editing the model. In grid view we added a edit button when it will be clicked that record will be edited in an ajax form. And i think you also recommended the same thing in your reply. all we wanted is the width of the row which will be in edit mode should be same as the previous grid view row with non editable mode. I have attached 2 pic. you see it.

                  Kendo Grid view looks so cool. It actually sucks.

    Thanks and Regards
    Ranjit Swain
  4. Dimo
    Admin
    Dimo avatar
    8446 posts

    Posted 23 Apr 2013 Link to this post

    Hi Ranjit,

    Please try one of the following:

    1) Enable Grid scrolling via .Scrollable().

    2) Apply a fixed table layout to the Grid table via external CSS or via TableHtmlAttributes()

    Options 1) and 2) above are similar (scrolling sets fixed table layout) and they will work if the edit textboxes have no explicit large pixel widths applied. If this is the case...

    3) Modify the CSS selectors in your stylesheets, so that the edit textboxes do not receive width styles. They have width styles from the Kendo stylesheets, which should do the job.

    If you need further assistance on this matter, I will need a runnable demo to check what influences the Grid apperance.

    Finally, please bear in mind that we do not tolerate offensive language in our forums.

    Regards,
    Dimo
    the Telerik team
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
Back to Top