VS2010 .NET 4 Issue

Thread is closed for posting
9 posts, 0 answers
  1. Daniel Vaughan
    Daniel Vaughan avatar
    7 posts
    Member since:
    Feb 2010

    Posted 11 Feb 2010 Link to this post

    I have two projects in Visual Studio 2010 RC, and they are identical in all respects apart from one targeting .NET 3.5 and the other .NET 4.0. I have a reference in both to Telerik.OpenAccess 2009.3.1119.2, and both are Orm enabled from the OpenAccess menu.
    The .NET 3.5 builds without any problems. The .NET 4.0 project has a build error:
    Error 1 Unknown build error, 'Could not load type 'System.Collections.Specialized.INotifyCollectionChanged' from assembly 'System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'. Line 6 Position 67.'  D:\DevelopmentTestProjects\Dotnet4Test\Dotnet4Test\MainWindow.xaml 6 67 Dotnet4Test

    Please tell me why.

    Regards,
    Daniel Vaughan
  2. Jan Blessenohl
    Admin
    Jan Blessenohl avatar
    707 posts

    Posted 12 Feb 2010 Link to this post

    Hi Daniel Vaughan,
    This seems to be a problem in the Microsoft Xaml compiler. I have opened a support ticket at Microsoft and expect an answer today. As soon as I have a reaction I will try to solve this issus.

    Greetings,
    Jan Blessenohl
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. Jan Blessenohl
    Admin
    Jan Blessenohl avatar
    707 posts

    Posted 13 Feb 2010 Link to this post

    Hello Daniel Vaughan,
    Did you close your on ticket at Microsoft?

    Regards,
    Jan Blessenohl
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  4. Daniel Vaughan
    Daniel Vaughan avatar
    7 posts
    Member since:
    Feb 2010

    Posted 13 Feb 2010 Link to this post

    Hi Jan,

    I don't have a ticket. I see that the issue on connect has been marked as Resolved as Not Reproducible. I don't know why.
  5. Jan Blessenohl
    Admin
    Jan Blessenohl avatar
    707 posts

    Posted 16 Feb 2010 Link to this post

    Hello Daniel Vaughan,
    Good news, the MS guys are working on it.

    Best wishes,
    Jan Blessenohl
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  6. Garry Clark
    Garry Clark avatar
    55 posts
    Member since:
    Jan 2005

    Posted 29 Mar 2010 Link to this post

    Jan,
    Any word on this as I am now getting this error?

    Unknown build error, 'Could not load type 'System.Collections.Specialized.INotifyCollectionChanged' from assembly 'System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'

    Thanks!
  7. Jan Blessenohl
    Admin
    Jan Blessenohl avatar
    707 posts

    Posted 01 Apr 2010 Link to this post

    Hi Garry Clark,
    Microsoft has fixed it but it is not available in an official release at the moment. If you have access to a newer version of VS (>RC) it will work.

    All the best,
    Jan Blessenohl
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  8. Garry Clark
    Garry Clark avatar
    55 posts
    Member since:
    Jan 2005

    Posted 01 Apr 2010 Link to this post

    Jan,
    Thanks for getting back to me. Apparently MSDN does nto have the latest and greatest out there. What avenues are avilable to get the patched version if possible?

    Thanks!
  9. Jan Blessenohl
    Admin
    Jan Blessenohl avatar
    707 posts

    Posted 06 Apr 2010 Link to this post

    Hi Garry Clark,
    You have to wait another week to get the RTM version via msdn I guess.

    Best wishes,
    Jan Blessenohl
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
Back to Top