UseStaticHeaders and autosize

2 posts, 0 answers
  1. Dennis
    Dennis avatar
    9 posts
    Member since:
    Nov 2008

    Posted 21 Jun 2013 Link to this post

    When you have a radgrid using UseStaticHeaders=True, the radgrid's width fills the browser.  If you resize the columns using best fit, sometimes, depending on how many columns you have, an empty column shows up filling the space between your last column and the radgrids right boundary.  How is this done?  I am trying to achieve the same effect using columns with HeaderWidths specified.  Do I just add an empty GridTemplateColumn?
  2. Angel Petrov
    Admin
    Angel Petrov avatar
    1144 posts

    Posted 26 Jun 2013 Link to this post

    Hi Dennis,

    When using resizing with scrolling and static headers only the GridTableView is resized - RadGrid's width remains fixed. The white space which you see is actually the difference between the width of the GridTableView and the grid. That said in order to achieve the same result you will have to enable the static headers and resizing functionality and set a width for the GridTableView smaller than the one of the grid.

    Regards,
    Angel Petrov
    Telerik
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to the blog feed now.
Back to Top