Uncaught TypeError: Cannot read property 'length' of null

Thread is closed for posting
3 posts, 0 answers
  1. Seokjoon
    Seokjoon avatar
    2 posts
    Member since:
    Nov 2014

    Posted 03 Nov 2014 Link to this post

    I am using Telerik, but these days, the application that I am working on doesn't work on mobile especially iPhones.
    It works fine with any other desktop version of web browsers. Safari for Desktop works fine.

    The problem is that, there is one dropdown menu and it is a javascript code. When I access with my iPhone, and tried to
    click the dropdown arrow, it does not take my input (touch). 
    When I tried to debug it, it says that there is

     "Uncaught TypeError: Cannot read property 'length' of null
    (anonymous function)
    (anonymous function)
    (anonymous function)

    Did anyone have the same problem or does anyone have ideas to solve problem?
    I really need your help to fix this issue.

    Thank you and have a great day!

  2. Maria Ilieva
    Maria Ilieva avatar
    4017 posts

    Posted 06 Nov 2014 Link to this post

    Hello Seokjoon,

    We have reports for similar issue in the Mobile Safari and it seems that the sites which are experiencing it are using ASP.NET 3.5. A fix is required for the browser definition files with the latest Safari release.

    You can see this stackoverflow thread and test the provided suggestions.
    I hope this tip would help you solve the issue faced.

    Maria Ilieva

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

  3. muhamed
    muhamed avatar
    1 posts
    Member since:
    Jun 2015

    Posted 19 Mar Link to this post

    Uncaught TypeError: Cannot read property 'length' of null
        at Telerik.Web.UI.RadAjaxManager.updateHeadStyles (ScriptResource.axd:303)
        at Telerik.Web.UI.RadAjaxManager.set_styles (ScriptResource.axd:102)
        at Function.Component$_setProperties [as _setProperties] (ScriptResource.axd:4574)
        at Component$create (ScriptResource.axd:4628)
        at <anonymous>:2:5
        at _Application$add_init [as add_init] (ScriptResource.axd:5692)
        at <anonymous>:1:17
        at _ScriptLoader$_loadScriptsInternal [as _loadScriptsInternal] (ScriptResource.axd:448)
        at _ScriptLoader$_loadScriptsInternal [as _loadScriptsInternal] (ScriptResource.axd:453)
        at _ScriptLoader$_loadScriptsInternal [as _loadScriptsInternal] (ScriptResource.axd:453)


    any kind of help highly appreciated

Back to Top