This is a migrated thread and some comments may be shown as answers.

TypeScript 0.9.0 support

3 Answers 160 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Halstein Tonheim
Top achievements
Rank 1
Halstein Tonheim asked on 19 Jun 2013, 07:52 AM
TypeScript 0.9.0 was just released (http://blogs.msdn.com/b/typescript/archive/2013/06/18/announcing-typescript-0-9.aspx), but the kendo.all.d.ts typescript definitions aren't compatible with it. The TypeScript 0.9.0 compiler throws 20 errors about "'declare' modifier required for top level element.".

Any ETA on a typescript type definition file that supports TypeScript 0.9.0?

3 Answers, 1 is accepted

Sort by
0
Atanas Korchev
Telerik team
answered on 19 Jun 2013, 08:41 AM
Hi,

 Indeed TypeScript 0.9 isn't backwards compatible and as a result the Kendo UI TypeScript definitions are broken. Fortunately it was an easy fix. Find the updated definitions attached.

Regards,
Atanas Korchev
Telerik
Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
0
Donald
Top achievements
Rank 1
answered on 10 Apr 2014, 01:47 PM
This seems to be broken again, in the latest version of Kendo UI
0
Atanas Korchev
Telerik team
answered on 14 Apr 2014, 06:49 AM
Hello,

This is a known issue which we have addressed in the latest internal build.

Regards,
Atanas Korchev
Telerik
 
Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
 
Tags
General Discussions
Asked by
Halstein Tonheim
Top achievements
Rank 1
Answers by
Atanas Korchev
Telerik team
Donald
Top achievements
Rank 1
Share this question
or