This is a migrated thread and some comments may be shown as answers.

The type initializer for 'Lock' threw an exception.

1 Answer 133 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
สุเมธ
Top achievements
Rank 1
สุเมธ asked on 13 Jan 2018, 03:44 AM

It's work properly when i start project with .Net Framework and select ASP.NET Core 2.0.

But I got this error after created project with .Net Core and select ASP.NET Core 2.0
https://imgur.com/ky68CAI

And i got question its impossible to run your report on Redhat os?

Thank you sir.

1 Answer, 1 is accepted

Sort by
0
Katia
Telerik team
answered on 17 Jan 2018, 02:13 PM
Hi,

Telerik Reporting NuGet packages are built against the full .NET Framework because the Reporting engine relies on the GDI+ API. Therefore, the packages will not work in the project that targets .NET Core framework as GDI+ is missing there.

If you wish to use the packages in .NET Core project use the following steps for creating the project:

1. In the New Project dialog, expand Installed > Visual C# > .NET Core, and select ASP.NET Core Web Application project template.
2. On the New ASP.NET Core Web Application dialog select from the drop downs .NET Framework and ASP.NET Core 2.

It is important to select .NET Framework from the drop down on the second step as this will set full .NET framework as the target framework of the project. Please check HTML5 Report Viewer in ASP.NET Core 2 help article for further instructions on how to host the service and add HTML5 Viewer to this type of projects.

If the above requirement cannot be met you can add just HTML5 Viewer in the project as it does not require any NuGet packages. Reporting REST service can be hosted separately in a project that targets full .NET framework. HTML5 Viewer will only need the address of the service set as its serviceUrl option.

Telerik Reporting can run on Windows machines only - 
System Requirements. Therefore, it is not possible to run reports in Linux environment. We receive an increasing amount of requests from our community related to rendering of reports in Linux. We are monitoring the available tools and libraries which we can switch to in order to provide such support. 
Feel free to share your ideas in the comments for REST Report service exposing the report generation engine on Linux request logged into our feedback portal. This will help us to measure the demand for this feature, see what is expected from it and to decide if we need to move forward in this direction.


Regards,
Katia
Progress Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
asdas
Top achievements
Rank 1
commented on 30 Aug 2021, 07:50 AM

This makes no sense at all. How do you think somebody will downgrade the target framework version of .net core from 3.1 to 2.0.
Todor
Telerik team
commented on 02 Sep 2021, 06:40 AM

The post is related to older Telerik Reporting versions.

Starting with R1 2019 (13.0.19.116) we support fully the .NET Core framework. We provide also NuGet packages for the different .NET Core versions.

Tags
General Discussions
Asked by
สุเมธ
Top achievements
Rank 1
Answers by
Katia
Telerik team
Share this question
or