This is a migrated thread and some comments may be shown as answers.

Templates of Hierarchical

1 Answer 28 Views
GridView
This is a migrated thread and some comments may be shown as answers.
KawaUser
Top achievements
Rank 2
KawaUser asked on 21 Mar 2011, 06:58 PM
When setting allow add new rows to false in my template, the template disappears when I run it in debugger. I have 2 other tabs that are working just fine, but when I try to add this third one it is being really buggy.

added:
After continuing to work on the project, it seems that there is an elusive template running about. I have now hit rock bottom and have deleted the grid view and now starting over. When I have not bounded anything to the grid view I go in to relations and it still says there is a child template of "Material List", BUT THERE SHOULDN'T BE. The templates collection is blank. How do I get rid of this?

added:
I ctrl + f for "MaterialList" to find that it was still embedded in code behind. I got rid of it and now it works, but there is a new problem.
I have a composite key on the table.

Reject Report:
Primary Keys: Reject_ID and Revision

Parts List
References: FK_REJECT_ID AND FK_REVISION

When I add to the parent and child column names of the relation, just the first key "REJECT_ID" AND "FK_REJECT_ID" it works, but pulls back materials for all revisions if there is more than one. Then, if I add the second set of column names it does not return anything. It actually doesn't even show the tab.

Do I need to do something different when messing with composite keys?

Thanks,
Chuck

1 Answer, 1 is accepted

Sort by
0
Accepted
Julian Benkov
Telerik team
answered on 24 Mar 2011, 09:44 AM
Hi KawaUser,

Please review your data and verify that it is contains related data with a composition key. If you continue to experience the issue, please send a small part of your related tables to debug the problem locally. Thank you in advance.

Greetings,
Julian Benkov
the Telerik team
Tags
GridView
Asked by
KawaUser
Top achievements
Rank 2
Answers by
Julian Benkov
Telerik team
Share this question
or