This is a migrated thread and some comments may be shown as answers.

Tab adds Whitespace

3 Answers 28 Views
ListView (Mobile)
This is a migrated thread and some comments may be shown as answers.
axel
Top achievements
Rank 1
axel asked on 21 Feb 2017, 08:50 PM

Hi,

tabulator appends whitespace to listview when target element is partial or completely outside clientview and you cannot scroll back to the top.

Is there a fix?

 

Kind regards

Axel

3 Answers, 1 is accepted

Sort by
0
Tsvetina
Telerik team
answered on 23 Feb 2017, 02:23 PM
Hi Axel,

I am not sure if I understand the problem that you are describing, but if you encounter issues with scrolling back to top after focusing an input in the ListView that is further down the view, it is possible to be an issue with the emulated scrolling in mobile views. Try setting data-use-native-scrolling="true" in the View, where your Mobile ListView is placed.
You can learn more about the specifics of native scrolling from this article:
Native vs. Emulated Scrolling

If the issue is different, please elaborate a bit more on your scenario. You could send us screen shots or a sample with reproduction steps to help us reproduce and investigate the problem faster.

Regards,
Tsvetina
Telerik by Progress
Try our brand new, jQuery-free Angular 2 components built from ground-up which deliver the business app essential building blocks - a grid component, data visualization (charts) and form elements.
0
axel
Top achievements
Rank 1
answered on 24 Feb 2017, 02:54 PM

Hi Tsvetina,

native scrolling doesn't fix it.

http://http//dojo.telerik.com/IlEPa

1. select first listview item

2. press tab until listview scrolls to next item.

3. try to scroll back to the top.

Attached screenshot shows additional whitespace in scroll-wrapper.

 

Kind regards

axel

0
Tsvetina
Telerik team
answered on 24 Feb 2017, 03:49 PM
Hi Axel,

This happens because the View native scrolling feature is ignored by the Dojo in Web mode. You can see the actual result in one of the following two ways:

1) Add useNativeScrolling: true option in the Application initialization logic to apply this setting globally for the app (will break ListViews with endless scrolling feature enabled).
var app = new kendo.mobile.Application(document.body, { skin: "nova", useNativeScrolling: true });

OR
2) Switch the Dojo preview to Simulator mode.

Regards,
Tsvetina
Telerik by Progress
Try our brand new, jQuery-free Angular 2 components built from ground-up which deliver the business app essential building blocks - a grid component, data visualization (charts) and form elements.
Tags
ListView (Mobile)
Asked by
axel
Top achievements
Rank 1
Answers by
Tsvetina
Telerik team
axel
Top achievements
Rank 1
Share this question
or