Strange thing happening with RadMenu

3 posts, 0 answers
  1. CyclingFoodmanPA
    CyclingFoodmanPA avatar
    6 posts
    Member since:
    Dec 2010

    Posted 16 Feb 2011 Link to this post

    I am getting the same error message as follows: "The tag 'RadMenu' does not exist in the XML namespace ''.  I have been battling with this for a couple of days and it is bugging me big time.  Now, I am running XP w/SP3 at work and I am running Win 7 32bit at home.

    I did get the menus to work at home.  I do have Telerik.Windows.Controls and Telerik.Windows.Controls.Navigation added as references.  I even removed the references and re-added them to see if that would work.

    I type in <telerik: in the xaml file and I see <telerik:RadHtmlPlaceholder and <telerik:RadNavigationButton but no RadMenu in between.

    I have created a sample project and get the same error (thought it may be something in my main project, but I am getting the same thing in the sample (which is good - consistancy, and bad - darn, I was hoping it would work).

    Any ideas?


    I am at home now and I copied the menu project that I created at work and all is ok.  So, on my machine at home, with Win 7 32 bit Ultimate, VS 2010 Ultimate all is ok. But at work, with Win XP w/SP3 and VS 2010 Pro. I am not seeing the RadMenu.  I go into the Object Browser and see the RadMenu under Telerik.Windows.Controls under Telerik.Windows.Controls.Navigation.  Not sure what to add to try and help as I am baffled on this.

    Hope you guys can figure something out.

  2. Boyan
    Boyan avatar
    758 posts

    Posted 21 Feb 2011 Link to this post

    Hi CyclingFoodmanPA,

    I tested the issue on XP and VS2010 but was not able to reproduce it. Everything was working fine at my side. This is a very strange problem indeed. You can try to use:

    instead of '" and see what happens.

    the Telerik team
    Registration for Q1 2011 What’s New Webinar Week is now open. Mark your calendar for the week starting March 21st and book your seat for a walk through all the exciting stuff we ship with the new release!
  3. Louis
    Louis avatar
    86 posts
    Member since:
    Aug 2013

    Posted 29 Aug 2013 Link to this post

    I realize it's an old post, but I came across the same problem and found this article. I found the solution, and am posting for anyone else who happens to run across it. I had the same (very strange) symptoms with telerik:RadCartesianChart; the problem turned out to be that the project was set up for .NET Framework 4, but I had the 4.5 dll's loaded in the project. Switching the project to .NET Framework 4.5 fixed the problem.
Back to Top