This is a migrated thread and some comments may be shown as answers.

Splitted link on RadLabel

7 Answers 61 Views
Label
This is a migrated thread and some comments may be shown as answers.
Pierre Alain
Top achievements
Rank 1
Pierre Alain asked on 03 Jun 2010, 05:05 PM
We recently updated to Q1 2010 SP2.

We have a RadLabel on a form with the the following for the text property:

<html><a href="about:blank">Advanced Mode</a></html>

This worked fine before SP2, but now it display with no underline where there is a space. In other words, instead of having Advanced Mode underlined as a link, only the 2 words are underline, making it appear as these are two different links.

How do I fix this?

7 Answers, 1 is accepted

Sort by
0
Peter
Telerik team
answered on 08 Jun 2010, 03:59 PM
Hello pacarrier,

Thank you for the provided information.

We will address the issue concerning the Links rendering in the Html-Like feature in one of the next releases. Unfortunately, there is no workaround available for the time being.

Your Telerik points have been updated for the report. Do not hesitate to contact us if you have other questions.

Greetings,
Peter
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
0
Pierre Alain
Top achievements
Rank 1
answered on 08 Jun 2010, 04:23 PM
Thank you. Any idea when that will be?
0
Peter
Telerik team
answered on 14 Jun 2010, 12:15 PM
Hi pacarrier,

We did made some changes in Telerik Presentation Framework and implemented BaseLine support. This action, however, has led to the described issue. We will probably address it in the next release.

Thank you for the understanding.

Sincerely yours,
Peter
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
0
Pierre Alain
Top achievements
Rank 1
answered on 08 Apr 2011, 09:26 PM
This is still an issue in 2011.1.11.315.
0
Peter
Telerik team
answered on 12 Apr 2011, 05:27 PM
Hello pacarrier,

Thank you for writing.
 
Some fonts do not report correctly their text metrics and we experienced this with MS Sans Serif. Is it possible to change the font to Segoe UI and test this?
 
About the links - we did not manage to solve the issue and I want to propose a simple workaround - to put _ instead of space in the link name.

We also appreciate if you send us a sample application with your scenario.
 
Thank you for your time and co-operation.

Kind regards,
Peter
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
0
Pierre Alain
Top achievements
Rank 1
answered on 22 Apr 2011, 07:56 PM
Hi,

the font is already Segeo UI. Change the space to _ did resolve the issue.

I will send an example solution in a support ticket.
0
Nikolay
Telerik team
answered on 27 Apr 2011, 10:14 AM
Hi pacarrier,

I am glad to hear that the underscore symbol has helped in this case. We will do the necessary research and will think of how we can improve the current implementation. At this time, however, I am not able to provide you with a specific time frame.

Regards,
Nikolay
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Tags
Label
Asked by
Pierre Alain
Top achievements
Rank 1
Answers by
Peter
Telerik team
Pierre Alain
Top achievements
Rank 1
Nikolay
Telerik team
Share this question
or