This is a migrated thread and some comments may be shown as answers.

service reference can not be added

9 Answers 62 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Arash Dastnai
Top achievements
Rank 1
Arash Dastnai asked on 29 Mar 2010, 04:52 PM
Hi,

I just bought the developers edition with version 2010 q1, but when i add the new telerik .dlls i cannot add any new service reference...it cannot build!/ generate the proxies...

however by using the trial version, which is a version lower (got it a few months ago)...i dont have any problems adding new service references!

additionally, the radpanes...are mixed up... i cannot set a new content for a radpane..... nothing happens...although i can debug it and see that the values are corret.
But it just seems like the radpane does not get updated or something

ps. the whole project works fine when using the trial and "older" version. the only thing I did was to remove the old .dlls and add the new ones from the 2010 q1 developers edition

9 Answers, 1 is accepted

Sort by
0
Grtjn
Top achievements
Rank 1
answered on 30 Mar 2010, 09:15 AM
Hi,

I have the same issue. I both have the Q3 2009 version and the Q1 2010 version.
I just upgraded to Q1 2010 and wanted to built my project and i get some errors my servicereference.

When using Q3 2009 I didn't get any errors at all and everything worked fine.

Any help?

Kind regards,

Gertjan
0
Konstantina
Telerik team
answered on 01 Apr 2010, 08:36 AM
Hi guys,

Thank you for contacting us.

Could you please share with us the errors that you are getting? Also, please provide us with more details, in order to find what might be causing the issue - are you using Telerik Silverlight Template, have you converted your project to VS 2010, and everything else which you consider essential.

Looking forward to your reply.

Regards,
Konstantina
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
0
Grtjn
Top achievements
Rank 1
answered on 15 Apr 2010, 07:51 AM
Hi

Sorry for my late reply...

Error   11  Custom tool error: Failed to generate code for the service reference 'ServiceReference'.  
Please check other error and warning messages for details.    C:\Users\gertjan.demeyer\Documents\Visual Studio 2008\
Projects\Pie_Rad_Trend3\Pie_Rad_Trend\Service References\ServiceReference\Reference.svcmap    1   1   Pie_Rad_Trend  
 

Error   15  The type or namespace name 'ServiceReference' does not exist in the namespace 'Pie_Rad_Trend' 
(are you missing an assembly reference?)  C:\Users\gertjan.demeyer\Documents\Visual Studio 2008\Projects\Pie_Rad_Trend3\
Pie_Rad_Trend\MainPage.xaml.cs    12  21  Pie_Rad_Trend  
 

Error   16  The type or namespace name 'WebServiceSoapClient' could not be found 
(are you missing a using directive or an assembly reference?)  C:\Users\gertjan.demeyer\Documents\Visual Studio 2008\
Projects\Pie_Rad_Trend3\Pie_Rad_Trend\MainPage.xaml.cs    23  9   Pie_Rad_Trend  
 

Error   17  The type or namespace name 'DashBoardCompletedEventArgs' could not be found 
(are you missing a using directive or an assembly reference?)   C:\Users\gertjan.demeyer\Documents\Visual Studio 2008\
Projects\Pie_Rad_Trend3\Pie_Rad_Trend\MainPage.xaml.cs    129 54  Pie_Rad_Trend  
 

And this goes on for every completedeventargs I have im my project. The only thing I did was change the references from Q3 2009 to Q1 2010, update my service reference and try to run the application.
Next I deleted the service reference and added a new one, but with the same result.

Hope you have an answer!

Kind regards,

Gertjan
0
Konstantina
Telerik team
answered on 20 Apr 2010, 07:59 AM
Hi Grtjn,

Thank you for the detailed information.

Could you please try to put the old assemblies again and see if it works in that way?

Looking forward to your reply.

Greetings,
Konstantina
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
0
Grtjn
Top achievements
Rank 1
answered on 20 Apr 2010, 08:08 AM
Hi,

If you mean that I have to add the old references (Q3 2009) and then try to update the service reference, than i have already done this. And then everything works again. No errors occur.

Gertjan
0
Konstantina
Telerik team
answered on 22 Apr 2010, 12:01 PM
Hi Grtjn,

Thank you for your patience with us.

This is really strange situation, that haven't occurred before. Could you please be so kind to send us a sample project in which that is reproducible. In that way we will be able to track down the source of the problem and provide you with a solution in a timely manner.

Looking forward to your reply.

Sincerely yours,
Konstantina
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
0
Grtjn
Top achievements
Rank 1
answered on 22 Apr 2010, 12:39 PM
Hi,

How can i attach a project ?

Info on the project:
I created this project in Q3 2009 and when running, it properly showed the graph.
Next I changed the references to Q1 2010. When running, now I again get the graph and in another layout.
So all normal till here.

Now when I update my service reference, the errors appear and running the project gives a strange, incorrect result. ( So i click the yes button, despite the fact that there are errors).

Plz provide an answer soon so i can send you the project, and I hope you can help me with this.

Gertjan
0
Konstantina
Telerik team
answered on 27 Apr 2010, 11:24 AM
Hello Grtjn,

To attach a project you have to open a support ticket and attach it there.

Looking forward to your reply.

Kind regards,
Konstantina
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
0
Grtjn
Top achievements
Rank 1
answered on 27 Apr 2010, 12:29 PM
Hi,

Normally you should find my project in the support ticket.

Ticket ID is: 304355

Kind regards,

Gertjan

Tags
General Discussions
Asked by
Arash Dastnai
Top achievements
Rank 1
Answers by
Grtjn
Top achievements
Rank 1
Konstantina
Telerik team
Share this question
or