This is a migrated thread and some comments may be shown as answers.

scheduler browser zoom bug

3 Answers 102 Views
Scheduler
This is a migrated thread and some comments may be shown as answers.
Tony
Top achievements
Rank 1
Tony asked on 16 Jan 2017, 11:22 PM

I have noticed that when I zoom in and out on both firefox and chrome, the time slot cells at times align and are misaligned with the header cells. I understand that a similar issue exists with the kendo grid (http://www.telerik.com/forums/2-bugs-when-zooming-a-grid), however our application needs to be compliant with WCAG 2.0. There is a resize clause specifying that "1.4.4 Resize text: Except for captions and images of text, text can be resized without assistive technology up to 200 percent without loss of content or functionality. (Level AA)" ( https://www.w3.org/TR/WCAG20/#visual-audio-contrast-scale).

 

Please advise.

3 Answers, 1 is accepted

Sort by
0
Veselin Tsvetanov
Telerik team
answered on 18 Jan 2017, 12:26 PM
Hi George,

As my colleague Dimo mentioned in his reply in the forum thread, the misalignment of the columns is caused by "the fact that the scrollbars on the page are not zoomed proportionately to the other content". In order to avoid that, the Scheduler should be forced to display its full hours by not specifying height. Here you could find a simple implementation of the above.

Please, note also, that the larger font size should not be achieved by zooming browser as other layout issues may arise of that. The Kendo suite does not officially offer support for zoom levels of the browsers different, than the default 100%.

Therefore, I would suggest you to set instead the the font-size to a greater value so the characters appear larger.

I hope, that the above helps you. If you have any further questions, please do not hesitate to contact us.

Regards,
Veselin Tsvetanov
Telerik by Progress
Try our brand new, jQuery-free Angular 2 components built from ground-up which deliver the business app essential building blocks - a grid component, data visualization (charts) and form elements.
0
Tony
Top achievements
Rank 1
answered on 20 Jan 2017, 05:30 PM

Hi Veselin,

Your colleague had mentioned a solution to my issue to disable Grid scrolling. Is this done through css or as a property set in the scheduler? I am using MVVM, may you please provide an example of this in that format? 

 

Also, disabling grid scrolling-- will this adversely affect the scheduler when it comes to responsive design? My scheduler needs to work in both mobile/tablet/desktop. 

 

Thank you!

0
Veselin Tsvetanov
Telerik team
answered on 24 Jan 2017, 10:10 AM
Hello George,

You could disable scrolling by not specifying height for the Scheduler widget (which is a CSS only approach). Here you could find a sample of a Scheduler with disabled scroll (no height set). 

Setting no height to the Scheduler should not affect the responsiveness of the widget.

Regards,
Veselin Tsvetanov
Telerik by Progress
Try our brand new, jQuery-free Angular 2 components built from ground-up which deliver the business app essential building blocks - a grid component, data visualization (charts) and form elements.
Tags
Scheduler
Asked by
Tony
Top achievements
Rank 1
Answers by
Veselin Tsvetanov
Telerik team
Tony
Top achievements
Rank 1
Share this question
or