RADFORM in visual studio 2010

4 posts, 0 answers
  1. Jose Maria Andrew Sison
    Jose Maria Andrew Sison avatar
    2 posts
    Member since:
    Jan 2010

    Posted 26 Oct 2010 Link to this post

    hi guys,

    ive recently updated my visual studio 2008 to visual studio 2010. before doing it ive uninstalled telerik controls and also visual studio 2008.

    when i installed everything again. i did not encounter any error. but when i create a new project or opened an old project, and tried to add a Radform i could not add it. normally i just do a simple add item and then select the Radform. unfortunately, now cannot select the Radform nor could not see any item for radcontrols.

    hoping for your help.


  2. Peter
    Peter avatar
    1148 posts

    Posted 28 Oct 2010 Link to this post

    Hi Jose Maria Andrew Sison,

    Thank you for writing.

    Could you try to reinstall Visual Studio templates using the following command in Visual Studio command prompt:
    "devenv /installvstemplates"

    In addition, you could perform steps described here which explain how to install the templates manually.

    I hope this helps.

    All the best,

    the Telerik team


    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Bob
    Bob avatar
    41 posts
    Member since:
    Mar 2012

    Posted 02 Jul 2012 Link to this post

    Hi there,

    Occasionally, I receive an error when I attempt to add a new RadForm to my project.  I attempt to restart VS2010, but continue to receive the same error.  I have also followed the instructions about reloading the templates, and that has not worked.
    This is such a normal task of adding new forms that having errors like this is unacceptable, nor should I have to go through hoops everytime to "fix" the error.

    The error is as follows:

    [A]Telerik.BSX.WizardEngine.Configuration.ScenarioDefinition cannot be cast to [B]Telerik.VSX.WizardEngine.ConfigurationDefinition.  Type A originates from 'Telerik.VSX.WizardEngine, Version=2012.1.214.0, Culture=neutral, PublicKeyToken=0dfdc51bd06071b4' in the context 'LoadFrom' at location 'C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\Extensions\Telerik\Telerik Web UI VS Extensions\2012.1.214.0\Telerik.VSX.WizardEngine.dll'.  Type B originates from 'Telerik.VSX.WizardEngine, Version=2012.1.320.0 Culture=neutral, PublickKeyToken=0dfdc51bd06071b4' in the context 'LoadFrom' at location 'C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\Extensions\Telerik\Telerik WinForms VSExtensions\2012.1.320.0\Telerik.VSX.WizardEngine.dll'.

    So, what can I do to eliminate this error?


  4. Aylin
    Aylin avatar
    75 posts

    Posted 03 Jul 2012 Link to this post

    Hello Bob,

    I am sorry for the inconvenience.

    This problem is observed when more than one VSExtensions packages with different versions are used. The best workaround we found so far was to always keep the VSExtensions the same version. So I would recommend you to follow the steps below:

    1. Open Visual Studio 2010 and go to Tools -> Extension Manager...
    2. Uninstall all Telerik VSExtensions available in the Installed Extensions section of the Extension Manager. Note that the Visual Studio should be run as administrator.
    3. Open VS2010 and go to Tools -> Extension Manager. Go to the Online Gallery and in the Search field in the top right corner type Telerik.
    4. Download and install the VSExtensions deleted at step 1.
    5. Restart the studio and try again to add RadForm to your project.

    I hope this will help.

    Kind Regards,
    VSXTeam Aylin
    the Telerik team
    RadControls for WinForms Q2'12 release is now live! Check out what's new or download a free trial >>
Back to Top