This is a migrated thread and some comments may be shown as answers.

RadEditor Disable spellcheking and red underlines

1 Answer 27 Views
Telerik Trainer
This is a migrated thread and some comments may be shown as answers.
Manasi
Top achievements
Rank 1
Manasi asked on 07 May 2016, 10:43 PM

I have not included the AjaxSpellchecker in my EditorToolGroup. Also I tried removing the httphandler SpellCheckHandler.axd from my web.config.

But whenever I open my document (xml file ) to edit in RadEditor, it underlines all the xml names/attributes with red color like spell checking.

I don't want any kind of spell check as well as those red underlines.

How do I achieve this?

Thanks.

1 Answer, 1 is accepted

Sort by
0
Ianko
Telerik team
answered on 11 May 2016, 11:44 AM
Hello Manasi,

The curly red underline is a result of the browser spellchecker that can be disabled by using the spellcheck attribute

Here you are an example how to set it for the RadEditor content area using OnClientLoad event:
<telerik:RadEditor runat="server" ID="RadEditor1" OnClientLoad="OnClientLoad"></telerik:RadEditor>
 
<script>
    function OnClientLoad(sender, args) {
        sender.get_contentArea().setAttribute("spellcheck", "false");
    }
</script>


Regards,
Ianko
Telerik
Do you need help with upgrading your ASP.NET AJAX, WPF or WinForms projects? Check the Telerik API Analyzer and share your thoughts.
Tags
Telerik Trainer
Asked by
Manasi
Top achievements
Rank 1
Answers by
Ianko
Telerik team
Share this question
or