RadDock "Getting Started" - different icons and ArgumentException clicking on RadDock

4 posts, 1 answers
  1. Ian
    Ian avatar
    51 posts
    Member since:
    Apr 2009

    Posted 31 Jan 2011 Link to this post

    I'm just taking my first look at the RadDock control. The "Getting Started" instruction seems very straightforward, advising me to add a reference to Telerik.Windows.Controls.Docking to the project and then select the RadDock control from Blend's Assets.

    The documentation is here: http://www.telerik.com/help/silverlight/raddocking-getting-started2.html 

    The first alarm bell is the icon shown on the screenshot is different from that you get (which is a push-pin button not the angled bracket icon shown in the documentation - screenshot attached)

    When you click the icon it just sits in the toolbar greyed out. You have to go back in and select it again and then it changes to a selectable state, but simply double-clicking on the RadDock control does nothing other than crash the designer with "An Exception was thrown: ArgumentException: Property Width not found in the property collection".

    I have tried this on one PC running Windows XP, Blend 4 and 2010 SP3 SP1  and on another PC running Windows 7, Blend 4 and 2010 SP3 (without the SP1).  The problem is easily reproducible and gives me no confidence in the control at all - I haven't even started doing anything with it yet just tried to add it to an empty user control.

    What am I missing?
  2. Answer
    George avatar
    1332 posts

    Posted 03 Feb 2011 Link to this post

    Hello Ian,

    I will paste my answer in your support ticket here: 

    In order to add the RadDocking control to your project, you need to add the following assemblies:

    • Telerik.Windows.Controls.dll
    • Telerik.Windows.Controls.Navigation.dll
    • Telerik.Windows.Controls.Docking.

    We will update our online documentation. Thank you for reporting this problems. I am glad to update your telerik points.

    Also, you could refer to our online examples about the RadDocking control - http://demos.telerik.com/silverlight/#Docking/FirstLook

    Please do not hesitate to contact us if you require any further information.

    the Telerik team
    Let us know about your Windows Phone 7 application built with RadControls and we will help you promote it. Learn more>>
  3. Ann
    Ann avatar
    1 posts
    Member since:
    Jan 2011

    Posted 08 Feb 2011 Link to this post

    I am experiencing the same problem as what was indicated by Ian - I'm getting an ArgumentException in Expression Blend 4.  I've added all of the references that you suggested and am still having a problem (exception as well as the push-pin icon).  I can add the RadDocking control in Visual Studio without a problem.  I get nothing but errors with the RadDocking controls when I open my project in Expression Blend 4.

    Please advise.

  4. Boyan
    Boyan avatar
    758 posts

    Posted 11 Feb 2011 Link to this post

    Hello Ann,

    I am not able to reproduce the bad behavior. If you have the RadControls installed by the installation(not just copied the assemblies) all Telerik controls should be in the assets already and you can use them without even adding the binaries to the project. Just drag the Docking icon from the Asset tab to the design surface and the assemblies needed should be automatically added to the project.

    I have recorded a short video how it should be working. Please, take a look at it and tell me if you are doing something else. Also be sure you are not creating Silverlight 3 project. You can also provide some more info on the version of Blend you are using and the version of the controls.

    Kind regards,
    the Telerik team
    Let us know about your Windows Phone 7 application built with RadControls and we will help you promote it. Learn more>>
Back to Top