This is a migrated thread and some comments may be shown as answers.

Problem with remote-markers databinding

3 Answers 34 Views
Map
This is a migrated thread and some comments may be shown as answers.
Wei Shiong
Top achievements
Rank 1
Wei Shiong asked on 20 Jan 2016, 03:38 PM

Hi,

     I'm testing out Kendo Maps and was running the remote-markers sample offline. I was expecting the markers to appear when I run the remote-markers.html file but they do not. Index.html is working fine though. It would be great if you could suggest the possible causes as to why this is so. By the way, I'm running Kendo Professional 2016.1.112.trial.

Best Regards,

CH

3 Answers, 1 is accepted

Sort by
0
T. Tsonev
Telerik team
answered on 22 Jan 2016, 08:56 AM
Hello,

The most common cause for this error is loading the demos from the file system. Google Chrome, for example, will disallow accessing the JSON files needed for the demos to run.

My advice is to host them in a web server and load them from there.

Regards,
T. Tsonev
Telerik
 
Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
 
0
Wei Shiong
Top achievements
Rank 1
answered on 23 Jan 2016, 05:33 PM

Hi,

    I've transferred the JSON files to my localhost root server and the markers do appear but only on the Internet Explorer browser. Any idea how I would be able to make it work on Chrome? Thanks in advance.

 Best Regards,

 CH

0
T. Tsonev
Telerik team
answered on 27 Jan 2016, 12:35 PM
Hi,

Shouldn't be much of a difference between the browsers, as much as the server is concerned.

Do you see any additional information in the developer tools network tab?

Regards,
T. Tsonev
Telerik
 
Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
 
Tags
Map
Asked by
Wei Shiong
Top achievements
Rank 1
Answers by
T. Tsonev
Telerik team
Wei Shiong
Top achievements
Rank 1
Share this question
or