Performance problem after using the EnableColumnVirtualization="False"

1 posts, 0 answers
  1. Dilip
    Dilip avatar
    23 posts
    Member since:
    Jun 2013

    Posted 12 Jun 2013 Link to this post

    <

     

     

    telerik:RadGridView Visibility="{Binding ManagesiteFileGridviewVisibility}"

     

     

     

    x:Name="ManageSiteOrderGrid"

     

     

     

    ItemsSource="{Binding ManageSiteFileOrders, Mode=TwoWay}"

     

     

     

    SelectedItem="{Binding SelectedSiteFileOrder, Mode=TwoWay}"

     

     

     

    IsSynchronizedWithCurrentItem="True"

     

     

     

    Margin="2"

     

     

     

    ShowInsertRow="False"

     

     

     

    ShowGroupPanel="False"

     

     

     

    AutoExpandGroups="False"

     

     

     

    IsFilteringAllowed="False"

     

     

     

    AutoGenerateColumns="False"

     

     

     

    ScrollViewer.HorizontalScrollBarVisibility="Auto"

     

     

     

    ScrollViewer.VerticalScrollBarVisibility="Auto"

     

     

     

    RowIndicatorVisibility="Visible"

     

     

     

    ValidatesOnDataErrors="InViewMode"

     

     

     

    DataLoadMode="Asynchronous"

     

     

     

    Grid.Row="2"

     

     

     

    Grid.Column="1"

     

     

     

    IsReadOnly="{Binding IsReadonlyProp}"

     

     

     

    CanUserFreezeColumns="False" RowEditEnded="ManageSiteOrderGrid_RowEditEnded"

     

     

     

    EnableColumnVirtualization="False"

     

     

     

    EnableRowVirtualization="False" >

     

     

     

     

    <telerik:RadGridView.Columns>

    Can someone please suggest me what i need to do to improve my performance, i have to use the

     

    EnableColumnVirtualization="False" inorder to resolve other problem like

    if i check the top row checkbox inside the radgrid, at the bottom row also checkbox is checking , it is very urgent.
Back to Top