overlay gradient not applied when setting series color value.

3 posts, 0 answers
  1. Mark
    Mark avatar
    8 posts
    Member since:
    Jan 2011

    Posted 10 Sep 2012 Link to this post

    Hi,

    I'm using Kendoui  Dataviz 2012.2.831 build and I'm playing with custom bar colors when using chart type = "column"
    If i set a series color in series declaration the columns get rendered flat color, even when I set overlay gradiant value to glass (which is the default value)

                series:
                    [{
                        field: "salesValue",
                        name: "Current Year",
                        color: "#ff0000"
                    },
                    {
                        field: "salesLastYearValue",
                        name: "Last Year",
                        color: "#00ff00",
                        overlay: {
                            gradient: "glass"
                        }
                    }],

    When I use the new property colorField and provide the same color values as columns im my dataset the chart columns are rendered with glass overlay.

    Is this a bug or the normal behavior...


  2. Hristo Germanov
    Admin
    Hristo Germanov avatar
    703 posts

    Posted 10 Sep 2012 Link to this post

    Hi Mark,

    Unfortunately I can't reproduce the issue. Could you please tell me in which browser I can reproduce the issue?

    All the best,
    Hristo Germanov
    the Telerik team
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
  3. Mark
    Mark avatar
    8 posts
    Member since:
    Jan 2011

    Posted 10 Sep 2012 Link to this post

    I have tried to reproduce this again and have to say that you are right, the "glass" effect is still applied, even when setting static color value for series. The problem was the color value itself. With values like "#ff0000" and "#00ff00" the glass effect is not visible, but when inspecting the colors generated on the columns I can see that the columns does not have a flat color.

    Sorry for this... maybe this is an indication for my next job.... cleaning up my screen ;-)

    Thx for support.
Back to Top