This is a migrated thread and some comments may be shown as answers.

npm warnings with wrappers

3 Answers 90 Views
This is a migrated thread and some comments may be shown as answers.
Dean
Top achievements
Rank 1
Dean asked on 28 Apr 2018, 12:47 AM

Seeing some peer warnings for 7 of the wrapper packages due to dependencies on earlier versions, can these be ignored or is this a bug where the package.json for each of these is referring to earlier releases? I'm importing from @progress/kendo-all-vue-wrapper which is from the 2018.1.313 release.

+-- @progress/kendo-gauges-vue-wrapper@2018.1.313
| +-- @progress/kendo-base-components-vue-wrapper@2017.3.1026
| `-- UNMET PEER DEPENDENCY @progress/kendo-ui@~2017.3.1026
+-- @progress/kendo-listbox-vue-wrapper@2018.1.313
| +-- @progress/kendo-base-components-vue-wrapper@2017.3.1026
| `-- UNMET PEER DEPENDENCY @progress/kendo-ui@~2017.3.1026
+-- @progress/kendo-listview-vue-wrapper@2018.1.313
| +-- @progress/kendo-base-components-vue-wrapper@2017.3.914
| `-- UNMET PEER DEPENDENCY @progress/kendo-ui@~2017.3.913
+-- @progress/kendo-map-vue-wrapper@2018.1.313
| +-- @progress/kendo-base-components-vue-wrapper@2017.3.1026
| `-- UNMET PEER DEPENDENCY @progress/kendo-ui@~2017.3.1026
+-- @progress/kendo-mediaplayer-vue-wrapper@2018.1.313
| +-- @progress/kendo-base-components-vue-wrapper@2017.3.1026
| `-- UNMET PEER DEPENDENCY @progress/kendo-ui@~2017.3.1026
+-- @progress/kendo-spreadsheet-vue-wrapper@2018.1.313
| +-- @progress/kendo-base-components-vue-wrapper@2017.3.1026
| `-- UNMET PEER DEPENDENCY @progress/kendo-ui@~2017.3.1026
+-- @progress/kendo-treemap-vue-wrapper@2018.1.313
| +-- @progress/kendo-base-components-vue-wrapper@2017.3.1026
| `-- UNMET PEER DEPENDENCY @progress/kendo-ui@~2017.3.1026

3 Answers, 1 is accepted

Sort by
0
Veselin Tsvetanov
Telerik team
answered on 01 May 2018, 12:44 PM
Hello Dean,

The observed is an issue in some of the Kendo Vue wrapper packages which should be resolved. Therefore, we have included such task in our internal backlog. As a small token of gratitude for the reported, I have updated your Telerik points.

As per the warning messages, the versions difference observed should not result in issues in the wrappers functionality. Nevertheless, if you observe any problem that might be related to the discussed, please let us know.

Regards,
Veselin Tsvetanov
Progress Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
0
K
Top achievements
Rank 1
answered on 18 Jul 2018, 04:34 PM

Hi,

I am also seeing these warning messages below. When do you think these will get resolved?

npm WARN @progress/kendo-base-components-vue-wrapper@2018.2.53-0.6041444 requires a peer of @progress/kendo-ui@~2018.1.313 but none is installed. You must install peer dependencies yourself.
npm WARN @progress/kendo-base-components-vue-wrapper@2018.2.53-0.6041444 requires a peer of @progress/kendo-ui@~2018.1.313 but none is installed. You must install peer dependencies yourself.
npm WARN @progress/kendo-base-components-vue-wrapper@2018.2.53-0.6041444 requires a peer of @progress/kendo-ui@~2018.1.313 but none is installed. You must install peer dependencies yourself.
npm WARN @progress/kendo-base-components-vue-wrapper@2018.2.53-0.6041444 requires a peer of @progress/kendo-ui@~2018.1.313 but none is installed. You must install peer dependencies yourself.
npm WARN @progress/kendo-theme-bootstrap@2.13.6 requires a peer of bootstrap@4.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN @progress/kendo-base-components-vue-wrapper@2018.2.53-0.6041444 requires a peer of @progress/kendo-ui@~2018.1.313 but none is installed. You must install peer dependencies yourself.

 

 

0
Veselin Tsvetanov
Telerik team
answered on 20 Jul 2018, 10:48 AM
Hi,

The version differences should be resolved within our next release (due in mid September). Until then you should be able to use the Vue wrappers despite the warnings with no issues.

Regards,
Veselin Tsvetanov
Progress Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Asked by
Dean
Top achievements
Rank 1
Answers by
Veselin Tsvetanov
Telerik team
K
Top achievements
Rank 1
Share this question
or