MVC Read.Data not calling javascript function

2 posts, 0 answers
  1. Steve
    Steve avatar
    13 posts
    Member since:
    Jun 2013

    Posted 20 Sep 2016 Link to this post

    This works:

    .Read(read => read.Action("StandardTableReadNull", "DashDataparts", new { AdditionalParam = "foo" })

    This doesn't:



    .Read(read => read.Action("StandardTableReadNull", "DashDataparts").Data("additionalData")
        function additionalData() {
            return {
                AdditionalParam: "foo"

    In the second example, the script never hit, so the parameter never got populated in our controller.  (In both cases, our Read controller action was hit, but the "AdditionalParam" parameter was only populated in the first example)

    We tried putting the script in our main js file, putting it on our view page, and putting it directly inline in the .Data call, none of which worked.

    Any thoughts why?  Any help would be greatly appreciated! :)



  2. Eyup
    Eyup avatar
    4073 posts

    Posted 22 Sep 2016 Link to this post

    Hi Steve,

    I've already replied to your support ticket with ID: 1063938. I suggest that we continue our conversation on the mentioned thread.

    Telerik by Progress
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top