Missing information in Slide Drawer Getting Started

3 posts, 1 answers
  1. N Mackay
    N Mackay avatar
    250 posts
    Member since:
    Dec 2010

    Posted 29 Oct 2015 Link to this post


    There's an important step missing in the documentation for this: 


    In iOS, after init of TelerikForms in FinishedLaunching you need to do:


    new Telerik.XamarinForms.PrimitivesRenderer.iOS.SideDrawerRenderer();

    It doesn't compile for ARM7 to a physical device otherwise.


    Kind Regards,




  2. Answer
    Pavel R. Pavlov
    Pavel R. Pavlov avatar
    1251 posts

    Posted 30 Oct 2015 Link to this post

    Hi Norman,

    Thank you for contacting us on that matter. I checked the referenced article and the instruction steps clearly state that the SideDrawerRenderer for iOS should be initialized before any other initialization (Xamarin or Telerik). I tested the code on device and it works as expected. In my opinion the referenced article leads users to correct setup of their project. I created a sample project following the instructions described in the article and tried to deploy it on iPhone 6, iPhone 5S and iPhone 6S and the code works as expected.

    Are you saying that there is an issue when you try deploying on a specific device? If so, what is the exact device that you tried deploying to?

    Pavel R. Pavlov
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. N Mackay
    N Mackay avatar
    250 posts
    Member since:
    Dec 2010

    Posted 30 Oct 2015 in reply to Pavel R. Pavlov Link to this post

    Hi Pavel,

    My mistake, I don't know why I missed that, I think in previous documention the full namespace was referenced so it was clearer. I honestly did miss that line.

    I did have an issue with the samples, the only way I could get it to deploy to hardware in iOS was to take my build settings from an existing iOS csproj file and manually edit the SDK iOS proj file, otherwise in Visual Studio 2013 it didn't allow me to swap between simulator and ARM7/iPhone etc.


    Thanks for clarifying,


Back to Top