This is a migrated thread and some comments may be shown as answers.

MinUnit not working

3 Answers 7 Views
Charts
This is a migrated thread and some comments may be shown as answers.
j
Top achievements
Rank 1
j asked on 05 Mar 2014, 10:45 PM
Hi,

I am trying a single example when the data of the chart is null or 0. But look at the X scale. It is 0, 0.2, 0.4...... etc..
I would like the scale to be 1, 2, 3, 4..etc

I have tried different ways but can acchieve this. I have used minUnit, min and doesn't work. It works using max, but that is not what i need.

Thanks
Jose

3 Answers, 1 is accepted

Sort by
0
Iliana Nikolova
Telerik team
answered on 06 Mar 2014, 09:58 AM
Hi Jose,

In order to achieve the expected result you should set xAxis.majorUnit 1. I.e.: 
$("#chart").kendoChart({
  //....
  xAxis: {
    //....
    majorUnit: 1
  },
});

Regards,
Iliana Nikolova
Telerik

DevCraft Q1'14 is here! Join the free online conference to see how this release solves your top-5 .NET challenges. Reserve your seat now!

0
j
Top achievements
Rank 1
answered on 13 Mar 2014, 05:07 PM
Still getting the same results. I am using a stacked bar chart.
0
T. Tsonev
Telerik team
answered on 14 Mar 2014, 07:45 AM
Hi,

In this case the majorUnit should be set on the valueAxis:

valueAxis: {
  majorUnit: 1
}


The xAxis settings are applicable only to scatter charts.
Apologies for the caused inconvenience.

Regards,
T. Tsonev
Telerik
 

DevCraft Q1'14 is here! Watch the online conference to see how this release solves your top-5 .NET challenges. Watch on demand now.

 
Tags
Charts
Asked by
j
Top achievements
Rank 1
Answers by
Iliana Nikolova
Telerik team
j
Top achievements
Rank 1
T. Tsonev
Telerik team
Share this question
or