This is a migrated thread and some comments may be shown as answers.

Loosing Italics tag in the editor

1 Answer 10 Views
Editor
This is a migrated thread and some comments may be shown as answers.
Rich
Top achievements
Rank 1
Rich asked on 28 Jun 2018, 01:18 PM

If I put this html code in the editor and then save it:

<table>
<tr>
<td>
<p><i class="fa fa-check" style="color: green;">&nbsp;</i></p>
</td>
</tr>
</table>

 

When I look at the HTML again it looks like this:

 

<table><tbody><tr><td>&nbsp;</td>
</tr>
</tbody></table>

It strips out the Italics tag. Normally this wouldn't be a problem but we using Font Awesome and this messes that up. I noticed that it only does this if it's in a table, if I put that same italics tag outside the table it works fine. I was able to verify this same behavior using the online demo page.

I am using Kendo UI v2018.1.221 


1 Answer, 1 is accepted

Sort by
0
Ianko
Telerik team
answered on 29 Jun 2018, 12:48 PM
Hi Rich,

Yes, the Kendo Editor has a special logic implemented to remove empty tags from the tables. If this functionality is disabled other side effects will arise and cause more troubles (e.g., redundant empty formmating tags). 

I can suggest you to include one more element that is hidden and has text. That will bypass the text processing of the table so that you can have the check mark. Here you are an example: https://dojo.telerik.com/oHIpusIL

Regards,
Ianko
Progress Telerik
Try our brand new, jQuery-free Angular components built from ground-up which deliver the business app essential building blocks - a grid component, data visualization (charts) and form elements.
Tags
Editor
Asked by
Rich
Top achievements
Rank 1
Answers by
Ianko
Telerik team
Share this question
or