This is a migrated thread and some comments may be shown as answers.

Kendo UI Treeview page jump in Internet Explorer

8 Answers 70 Views
TreeView
This is a migrated thread and some comments may be shown as answers.
Joao
Top achievements
Rank 1
Joao asked on 12 Feb 2014, 10:30 AM
If the treeview extends below the browsers visible height and causes a vertical scroll-bar, on clicking nodes within the treeview causes a page jump in Internet Explorer 11.
This bug was noticeable on the demos (http://demos.telerik.com/kendo-ui/web/treeview/index.html).

Is there a quick fix for IE11? As this bug does not appear when using Chrome or Firefox.

Thanks

8 Answers, 1 is accepted

Sort by
0
Alex Gyoshev
Telerik team
answered on 13 Feb 2014, 08:25 AM
Hello Joao,

This is caused because the TreeView keyboard navigation needs the TreeView div to be focused, and focusing it in IE scrolls the page. We revert to the previously scrolled position, but the whole process is visible sometimes. We are not aware of a resolution of the problem.

Regards,
Alex Gyoshev
Telerik
Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
0
DAC Beachcroft LLP
Top achievements
Rank 2
answered on 30 Jul 2014, 11:16 AM
Is there still no workaround for this issue?
0
Kiril Nikolov
Telerik team
answered on 01 Aug 2014, 07:18 AM
Hi Joao,

I am afraid that currently there is no workaround for this issue. As my colleague previously explained it is a problem with the way IE treats the focus and scrolls the page. 

Regards,
Kiril Nikolov
Telerik
 
Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
 
0
DAC Beachcroft LLP
Top achievements
Rank 2
answered on 01 Aug 2014, 09:42 AM
Hi Kiril,

I'm finding this issue makes the Tree View unuseable, since it will contain enough information to extend beyond the viewport, and my target browser is IE.

Is there no workaround, such as disabling keyboard navigation, that might avoid the need to trigger focus?

Many thanks,

Jamie
0
Kiril Nikolov
Telerik team
answered on 04 Aug 2014, 11:45 AM
Hi,

The keyboard navigation cannot be turned off with an option from the widgets configuration. You can try disabling it using the following code, but I am not really sure if this will fix the scroll behavior:

var tree = $("[data-role=treeview]").data("kendoTreeView");
tree.wrapper.off("focus keydown")
tree.focus = $.noop

However this is not the official and supported way of doing this.

Regards,
Kiril Nikolov
Telerik
 
Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
 
0
Chris
Top achievements
Rank 1
answered on 03 Nov 2014, 01:14 PM
Thanks, that workaround does indeed seem to resolve the issue (at least on ie10 and v2014.2.1008)

So to clarify your disclaimer.. "However this is not the official and supported way of doing this."

As there isn't a current official fix for this issue, how problematic might this workaround be?   i.e. any foreseen issues?

Are there plans to fix in kendo?

A resolution really is quite urgent, as for larger data sets, its very common for the tree to extend past current page...  and IE quite a common browser in corporate deployments!

Thanks

Chris
0
Alex Gyoshev
Telerik team
answered on 03 Nov 2014, 03:29 PM
Hello Chris,

FIxing this would mean disabling keyboard navigation. We don't offer an option for that at this time, and nobody has suggested an option for disabling this accessibility feature on UserVoice yet. We are not aware of a fix for this, because IE scrolls the page when the TreeView is focused. Theoretically, removing the focus/keydown handlers should work fine for the time being. You can suggest an option for disabling keyboard navigation on UserVoice.

Regards,
Alex Gyoshev
Telerik
 
Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
 
0
Ody
Top achievements
Rank 1
Veteran
answered on 14 Dec 2016, 05:25 AM

Just in case this happens for anyone else, I was able to fix my jumping issue by assigning a static height to the treeview control.

<div id="file-treeview" style="height: 400px;"></div>

 

Another way I had some success with it is by removing the click event on the treeview control and assigning click events to all the k-item nodes.  Then IE wasn't trying to focus the entire thing widget.

$("#file-treeview").off("click");
$("#file-treeview .k-item").on("click", function (e) {
        console.log(e.currentTarget.dataset.uid);
    });

 

Cheers

Tags
TreeView
Asked by
Joao
Top achievements
Rank 1
Answers by
Alex Gyoshev
Telerik team
DAC Beachcroft LLP
Top achievements
Rank 2
Kiril Nikolov
Telerik team
Chris
Top achievements
Rank 1
Ody
Top achievements
Rank 1
Veteran
Share this question
or