Kendo editor ,image browser create does not work

2 posts, 0 answers
  1. marko
    marko avatar
    20 posts
    Member since:
    Oct 2006

    Posted 25 Nov 2014 Link to this post

    I am struggling to create the image on the server and display the thumbnail, I am using to call a webservice in C #, the read method is working but the other not.
    already tried here in the forum and not found anything like it, if someone has any examples that I can see or some idea. the error and the following:
    the data is only for testing.
                tools: [
                ], imageBrowser: {
                    messages: {
                        dropFilesHere: "Drop files here"
                    transport: {
                        read: {
                            dataType: "json",
                            contentType: 'application/json; ',                   
                            type: "GET",
                            url: findRelativeBasePath() + "WebServices/Actions/Pages_fe_actions.svc/Pulls_Pages_fe"
                        create: {                     
                            type: "POST",
                            url: findRelativeBasePath() + "WebServices/Actions/Pages_fe_actions.svc/Push_Pages_fe",
                            data : {"name":"111.JPG","type":"f","size":"6832"}
                        thumbnailUrl: {                  
                            url: findRelativeBasePath() + "WebServices/Actions/Pages_fe_actions.svc/Push_Pages_fe",
                            data :  { formValues : ""}
                        uploadUrl: {                      
                            type: "POST",
                            url: findRelativeBasePath() + "WebServices/Actions/Pages_fe_actions.svc/Push_Pages_fe"   ,
                            data :  { formValues : ""}           
                        imageUrl: "../Images/{0}",
                        path: "../Images/"
  2. Dimo
    Dimo avatar
    8411 posts

    Posted 27 Nov 2014 Link to this post

    Hi Mark,

    The problem seems related to the server-side implementation. Have you tried debugging it? Is the file uploaded successfully? Is it saved to the desired folder successfully? Is the server response in accordance with the documentation?

    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
Back to Top