Incell number editing visual glitch

3 posts, 0 answers
  1. Gabriel
    Gabriel avatar
    7 posts
    Member since:
    Nov 2017

    Posted 10 May 2018 Link to this post

    Hey everyone,

    I came across an annoying visual glitch while implementing incell editing (default edit mode) with non-decimal numbers. When we enter the edit field of an said number (let's say value=14), for a brief moment the editor displays 14.00. This is easily reproducible in a clean dojo environment. I tried a couple of things to get rid of this but didn't succeed.

    Here is a dojo where each column represents what I've tried : 

    Standard: minimalist config that I used in the beginning
    Model Format: tried to force the format at the data source level
    Template: Tried to set a custom template with kendo.toString(value, "n0")
    Custom Editor: using a simple custom editor ( vale is lost here)
    Custom editor 2: using a custom editor and initializing the value (breaks model change)

    https://dojo.telerik.com/oYAvOlOZ

  2. Viktor Tachev
    Admin
    Viktor Tachev avatar
    2497 posts

    Posted 14 May 2018 Link to this post

    Hi Gabriel,

    In order to implement the behavior I can suggest couple of options. The first approach would be configuring columns.format to show only integer numbers.

    Another option is to use custom editor as illustrated in the Custom Editor example and define the format for the NumericTextBox editor.

    For your convenience I applied both approaches in the dojo sample. 


    Give it a try and let me know how it works for you.

    Regards,
    Viktor Tachev
    Progress Telerik
    Try our brand new, jQuery-free Angular components built from ground-up which deliver the business app essential building blocks - a grid component, data visualization (charts) and form elements.
  3. Gabriel
    Gabriel avatar
    7 posts
    Member since:
    Nov 2017

    Posted 15 May 2018 Link to this post

    Hey Viktor,

    thanks alot for the help it seems to work!

     

     

    Gabriel

Back to Top