Icenium can't see Android Novatech nTab II new tablet

2 posts, 0 answers
  1. Michael
    Michael avatar
    21 posts
    Member since:
    Apr 2011

    Posted 20 Dec 2013 Link to this post

    We have just purchased a Novatech nTab II tablet (NOV-NTAB29) and have 2 issues:

    1. We have switched debugging mode on and allow unknown sources on. We have tried different USB connection methods. We have several other Android devices all working properly. The Android ADB Driver looking OK and stating 'Device working properly'. We can turn USB Storage On & Off successfully. This is a new tablet that has a good spec and appears to have a standard 4.2.2 Android Install. 

    Despite all of this the device does not appear in Icenium Graphite and does NOT appear in the list when running C:\Users\****\AppData\Local\Temp\adb>adb devices as instructed in your post:

    What else can we check?

    2. The second problem is that despite the app being available to over 3200+ mobile devices on the Google Play store it says for this tablet (listed as Rockchip NOV-NTAB29) our app (1BizApp) is incompatible with this device. It does run on several other tablets with the same or different Android versions. we have tried at length changing various settings and permissions in Icenium and in the android manifest.xml file with no affect. Is there any way we can find out what is causing the Play store to think the app is incompatible?



  2. Iva Koevska
    Iva Koevska avatar
    286 posts

    Posted 24 Dec 2013 Link to this post

    Hello Michael,

    Unfortunately, we do not have a Novatech nTab II device at our disposal and are unable to test, reproduce, and troubleshoot your issue locally. Therefore, we can only suggest possible workarounds.

    If the adb command prompt does not list your device, then it is not properly installed and recognized by your system.

    Did you install a device-specific driver (an OEM one, or a third-party one) or did you try installing an universal ADB driver? (With the fragmentation of the Android market, it is usually the driver that causes issues with Graphite.)

    Another issue that you might be facing is having some sort of device management software that uses its own instance of adb.exe. If this software is running along with Graphite, conflicts might arise between Graphite's adb and the other adb process. If this is the case, close Graphite, run Task Manager to kill any adb/device management processes, and run Graphite again. And finally, make sure that you are not running the Icenium extension for Visual Studio and Graphite simultaneously.

    About your second question - it is usually a matter of setting up permissions (usually disabling SMS or Telephony) to make an Android app compatible with tablets. When configuring the permissions in Project Properties and in the configuration files, keep in mind that the enabled Apache Cordova core plugins might add their own required permissions during the build process. So, always make sure to disable the core plugins that you do not need.

    And last but not least, check if your app is configured to run on devices with the screen density of your Novatech tablet and make sure that your hardware acceleration settings comply with the specification of the tablet. 

    Iva Koevska
    You've missed the Icenium Visual Studio Integration keynote? It has been recorded and posted here.
    Looking for tips & tricks directly from the Icenium team? Check out our blog!
    Share feedback and vote for features on our Feedback Portal.
Back to Top