How can i turn off autoscroll for child control of RadPanelBar

Thread is closed for posting
2 posts, 0 answers
  1. Andreas Mildenberger
    Andreas Mildenberger avatar
    9 posts
    Member since:
    Mar 2010

    Posted 06 Sep 2010 Link to this post

    Hello every body,

    i want to display full size of an control (Panel) within an RadPanelBar.
    I just see a part of it. I have set AutoScroll = false, it turn back to true.

    How can i display the whole child control of RadPanelBar without seeing
    the scrollbar?

    Would you kindly help me? 
  2. Alexander
    Alexander avatar
    306 posts

    Posted 09 Sep 2010 Link to this post

    Hello Andreas,

    Thank you for your question.

    You can enable the scrollbars of e group's ContentPanel holding your controls by setting the AutoScroll property to true:
    radPanelBarGroupElement1.ContentPanel.AutoScroll = false;

    If you aim is to display the entire content without displaying scrollbars, you need to provide the appropriate size of the RadPanelBar control.

    Please note that the RadPanelBar control is obsolete and we highly encourage you to use the RadPageView control instead. It covers the functionality of RadPanelBar when used in Stack View Mode and offers much more features. You can use the RadPageViewPage instead of the RadPanelBarGroupElement and define its scrollbar visibility using:
    this.radPageViewPage1.AutoScroll = true;

    I hope it helps.

    Kind regards,
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Back to Top