This is a migrated thread and some comments may be shown as answers.

Grouping in scheduler doesn't work when setting data directly

1 Answer 35 Views
Scheduler
This is a migrated thread and some comments may be shown as answers.
Christiaan
Top achievements
Rank 1
Christiaan asked on 08 Oct 2016, 01:51 PM

I have a problem grouping the schedule. In the sample http://demos.telerik.com/kendo-ui/scheduler/resources-grouping-horizontal it shows how to achieve this, but if I replace the datasource with an array, it doesn't work anymore. As soon as I remove the grouping attribute the events show up in the scheduler.

You can find the repro in this dojo: http://dojo.telerik.com/UCUle/7. This has two scheduler controls, which are exact copies of each other, only the group is different. 

What am I doing wrong?

1 Answer, 1 is accepted

Sort by
0
Accepted
Vladimir Iliev
Telerik team
answered on 10 Oct 2016, 07:12 AM
Hello Christiaan,

After checking the provided demo it appears that the reason for current behavior is the group configuration - the filed name is mistyped with lowercase "d". Please check the updated configuration below:

resources: ["roomID"]

On a side note I would like to remind you that without defining the Scheduler dataSource "schema.model" option the editing is not supported. You should either define this option or disable the Scheduler editing to avoid unexpected behavior. 

Regards,
Vladimir Iliev
Telerik by Progress
 
Get started with Kendo UI in days. Online training courses help you quickly implement components into your apps.
 
Tags
Scheduler
Asked by
Christiaan
Top achievements
Rank 1
Answers by
Vladimir Iliev
Telerik team
Share this question
or