GridView appearing in Component Tray

5 posts, 1 answers
  1. Nordy
    Nordy avatar
    14 posts
    Member since:
    Aug 2007

    Posted 12 Nov 2007 Link to this post

    For some reason, when I drag a GridView instance on to my form, it appears in the Component Tray.  If I try to do anything with it, it never appears when I run the project.  It's as if the visual aspects of the control aren't working on my GridView control.  Any ideas?

    Thanks in advance.
  2. Answer
    Jordan avatar
    547 posts

    Posted 13 Nov 2007 Link to this post

    Hello Jamie Nordmeyer,

    This happens when the designer for RadGridView cannot be loaded by Visual Studio.

    This is the case, for example, when you have in GAC the design time assembly for version and in the design surface of Visual Studio you drag a RadGridView control with a version of

    Following are possible reasons for such behavior:
    1. The references to the Telerik assemblies in your project are broken. You could try to re-add these references.
    2. Your installation of RadControls for WinForms is invalid - there might be multiple versions of the same assembly in the GAC. You could try uninstalling all previous versions of RadControls for Winforms, then making sure the GAC does not have any RadControls for Winforms DLLs left. You should then re-install RadControls for WinForms, and make sure the GAC only contains DLLs bearing the latest version.
    Hope that helps. Contact us again if you have any additional questions.

    Best wishes,
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. Nordy
    Nordy avatar
    14 posts
    Member since:
    Aug 2007

    Posted 13 Nov 2007 Link to this post

    Hey, thanks for the quick reply!  I figured that out this morning.  The GridView simply hadn't added all the proper references.  When I added them in, it worked fine.

    Again, thank!
  4. Bruno Costa
    Bruno Costa avatar
    9 posts
    Member since:
    May 2010

    Posted 17 Jun 2010 Link to this post

    Hi Jamie,

    I have the same problem, I put all References:


    But the problem has continued. Dou you know why? The RadGrid Control appear only in Component Tray...
    Only work if I put this code in .designer: this.Controls.Add(radgrid1);
    I'm using VIsual Studio 2010 and 2009. The problem occurs in both. The RadGridView version: 2009.1.9.414

  5. Nikolay
    Nikolay avatar
    1805 posts

    Posted 22 Jun 2010 Link to this post

    Hi Bruno Costa,

    This can happen for one of the following reasons:
    - Your project does not have a reference to the Telerik.WinControls.UI.Design assembly;
    - The Telerik.WinControls.UI.Design assembly is not installed in the GAC.

    The solution is to either install the assembly in the GAC or to add a reference to it and rebuild your project.

    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Back to Top