This is a migrated thread and some comments may be shown as answers.

Grid is blank.

1 Answer 190 Views
Grid
This is a migrated thread and some comments may be shown as answers.
Kevin
Top achievements
Rank 1
Kevin asked on 03 Apr 2019, 02:38 PM

I have a grid that the datasource shows has data. Exporting the grid to Excel shows data. But the display shows no data in any of the columns. I am not sure how to debug this. Are there some hooks that I can verify that the data is making it to. The column headers show up just no data in each column.

 

Thank you.

 

Kevin

1 Answer, 1 is accepted

Sort by
0
Viktor Tachev
Telerik team
answered on 05 Apr 2019, 11:45 AM
Hello Kevin,

Based on the provided information it would be hard to pinpoint the exact cause of the behavior. Would you send us a runnable sample where the issue is replicated? This will enable us to examine it and look for its cause. 

With that said, I would suggest inspecting the Network tab in the browser Developer tools. Check the request that makes when reading the data and make sure that the response contains records. Also check if there are any errors - in case there are errors that could point us in the right direction.

Regards,
Viktor Tachev
Progress Telerik
Get quickly onboarded and successful with your Telerik and/or Kendo UI products with the Virtual Classroom free technical training, available to all active customers. Learn More.
Tags
Grid
Asked by
Kevin
Top achievements
Rank 1
Answers by
Viktor Tachev
Telerik team
Share this question
or