This is a migrated thread and some comments may be shown as answers.

Grid Header Space

6 Answers 125 Views
GridView
This is a migrated thread and some comments may be shown as answers.
Tom
Top achievements
Rank 1
Tom asked on 20 Feb 2008, 07:53 PM

How do I remove the white space above the grid columns?

I'm using the BusinessGrid theme and have looked everywhere trying to find how to remove this white space. It's at the very top of the grid above the header columns.

Thanks

6 Answers, 1 is accepted

Sort by
0
Jack
Telerik team
answered on 21 Feb 2008, 11:25 AM

Hi Tom,

Thank you for contacting me.

Right above the rows area, there is a white space used for the grouping panel. Once you drop a column in the grouping panel, the RadGridView will be grouped by this column. If you don't wish to use this feature you can hide the grouping panel by setting its Visibility to Collapsed. Consider the code below:

((GridTableElement)this.radGridView1.GridElement).Children[0].Visibility = Telerik.WinControls.ElementVisibility.Collapsed; 
 
 
 

I hope this helps. Do not hesitate to write me, if you have other questions.

Best regards,
Jack
the Telerik team

Instantly find answers to your questions at the new Telerik Support Center
0
Tom
Top achievements
Rank 1
answered on 21 Feb 2008, 01:39 PM

Yeah I figured that out. I feel stupid hahaha.

I do have another question. We have a form that has several grids on it stacked vertically. Vertical space in each grid is at a premium and I want to cut out any wasted space.

I changed the height of the header columns using the Visual style editor and changing the GridHeaderRowElement section. I changed the AutoSize property to false, and then changed the height in the bounds section.

This worked fine to change the height of the header column, however, the container section in still the original height.  How do I adjust the height of the container itself?

0
Jack
Telerik team
answered on 21 Feb 2008, 02:57 PM
Hello Tom,

The column header row uses the TableHeaderHeight property of the GridTableElement to get its size. When the AutoSize property is set to true, this behavior is broken. I woud suggest using the TableHeaderHeight property.

Let us know, if you need further assistance.
 

Kind regards,
Jack
the Telerik team

Instantly find answers to your questions at the new Telerik Support Center
0
Jared
Top achievements
Rank 2
answered on 01 Jun 2018, 04:42 PM
Is there a new way of hiding the white space for the grouping panel?  I've got the most recent version of the Telerik controls and the above code doesn't work anymore.  I also want to hide that white space above the row header that seems to be saved for the column group panel which I've already disabled.
0
Jared
Top achievements
Rank 2
answered on 01 Jun 2018, 05:50 PM

Here it is:

radGridView.ShowGroupPanel = false;
0
Dess | Tech Support Engineer, Principal
Telerik team
answered on 04 Jun 2018, 07:50 AM
Hello, Jared,  

I am glad that the problem you were facing is now resolved. You can also refer to the grouping section in the online documentation for any further information: https://docs.telerik.com/devtools/winforms/gridview/grouping/basic-grouping

I hope this information helps. If you have any additional questions, please let me know. 

Regards,
Dess
Progress Telerik
Try our brand new, jQuery-free Angular components built from ground-up which deliver the business app essential building blocks - a grid component, data visualization (charts) and form elements.
Tags
GridView
Asked by
Tom
Top achievements
Rank 1
Answers by
Jack
Telerik team
Tom
Top achievements
Rank 1
Jared
Top achievements
Rank 2
Dess | Tech Support Engineer, Principal
Telerik team
Share this question
or