This is a migrated thread and some comments may be shown as answers.

GetFullVsVersionString must be called on the UI thread.

16 Answers 356 Views
Installer and VS Extensions
This is a migrated thread and some comments may be shown as answers.
Steve
Top achievements
Rank 1
Steve asked on 23 Feb 2017, 07:25 PM
I am getting this error when I open my solution. Removing the Telerik Extensions in VS 2015.3 seems to have resolved it. Similar thread: http://stackoverflow.com/questions/39678601/visual-studio-2015-initializing-part-nuget-packagemanagement-visualstudio-vsolut/41753470?noredirect=1#comment71901895_41753470

16 Answers, 1 is accepted

Sort by
0
Nikolay Mishev
Telerik team
answered on 27 Feb 2017, 04:29 PM
Hi Steve,

Thank you for contacting us.

We are aware of the issue and for now I can suggest you to reinstall the NuGet Package Manager for Visual Studio through the Extensions & Updates tool and try the suggestions pointed here and let us know if the issue persists.

Regards,
Nikolay Mishev
Telerik by Progress
Try our brand new, jQuery-free Angular 2 components built from ground-up which deliver the business app essential building blocks - a grid component, data visualization (charts) and form elements.
0
Steve
Top achievements
Rank 1
answered on 27 Feb 2017, 07:45 PM

Yes, I tried that (that's my comment at the bottom of your link :)). I don't really need the extensions, so I'm working around it for now.

0
Nikolay Mishev
Telerik team
answered on 28 Feb 2017, 12:31 PM
Hi Steve,

I hope working around the issue is not causing inconvenience to you.

We have logged an item in our backlog and will further look into the matter. Based on the current information from the StackOverflow thread and the GitHub issue we can not draw a definitive conclusion where the problem is. Yet if we determine that the exception is caused by our product we will deploy a fix with one of our future releases.

If you have any other questions or face further difficulties please get back to us. 

Regards,
Nikolay Mishev
Telerik by Progress
Try our brand new, jQuery-free Angular 2 components built from ground-up which deliver the business app essential building blocks - a grid component, data visualization (charts) and form elements.
0
Rob Ainscough
Top achievements
Rank 1
answered on 31 May 2018, 04:44 PM

Over a year later I'm getting the same error message after I installed Telerik UI ASP.NET Core ... so I guess this problem was never addressed?

Can someone point me in a direction on how to remove the Telerik Extensions and what implications that might have with building/compiling my projects that use Telerik controls?

Rob.

 

0
Steve
Top achievements
Rank 1
answered on 31 May 2018, 07:26 PM
I have the extensions installed with no issues. Do you have recent versions? 2018.1 for me and VS 2017.
0
Rob Ainscough
Top achievements
Rank 1
answered on 31 May 2018, 08:53 PM

Yes I have the most recent version.  I was able to find a solution:

"In VisualStudio 2015 -> Tools -> Extensions and updates -> Online: Search for the string: "Fix NuGet GetFullVsVersionString must be called on the UI thread" and install the given fix."

from this thread: https://stackoverflow.com/questions/39678601/visual-studio-2015-initializing-part-nuget-packagemanagement-visualstudio-vsolut/41753470?noredirect=1#comment71901895_41753470

I'm using VS 2015.

Rob.

 

0
Rob Ainscough
Top achievements
Rank 1
answered on 31 May 2018, 09:01 PM

EDIT:

I take it Telerik are not going to address the issue, given it's recurring and been over a year since this post?

The trigger for this error was installing Telerik UI for ASP.NET Core (2018.2.516) from latest version of Progress Control panel (

Rob.

0
Nikolay Mishev
Telerik team
answered on 01 Jun 2018, 01:57 PM
Hi Rob,

Thank you for contacting us.

I want to apologize but we are still unable to reproduce this issue and the only report for it is coming from this thread. With that said the workaround I can recommend you is to remove our Visual Studio Extensions. I want to assure you that removing the Extension is not going to affect building or compiling projects that contains Telerik controls. Please check this step that should guide you through:
  1. Open Visual Studio
  2. Go to Tools -> Extensions and Updates...
  3. Under the Installed tab search for Telerik ASP.NET Core VSExtensions
  4. Click on the Uninstall button
  5. Restart Visual Studio

Regards,
Nikolay Mishev
Progress Telerik
Try our brand new, jQuery-free Angular components built from ground-up which deliver the business app essential building blocks - a grid component, data visualization (charts) and form elements.
0
Zakhaliya Ivarnovich
Top achievements
Rank 1
answered on 30 Jan 2021, 10:00 PM

I have visual studio 2015 Enterprise Update 3.

When i installed R1 2017 on it i faced that error too.

By Disabling extensions from Tools -> Extensions and Updates...error vanished.

What is going on & why telerik has no solution for this?

==============================================

"In VisualStudio 2015 -> Tools -> Extensions and updates ->
Online: Search for the string: "Fix NuGet GetFullVsVersionString must be
called on the UI thread" and install the given fix."

 

I did it and found nothing.

Where is that extension to fix this issue?

What did they remove it from marketplace?

0
Zakhaliya Ivarnovich
Top achievements
Rank 1
answered on 30 Jan 2021, 10:03 PM

[EDIT]

I have visual studio 2015 Enterprise Update 3.
When i installed Telerik R1 2017 on it i faced that error too.
By Disabling extensions from Tools -> Extensions and Updates...error vanished.
What is going on & why Telerik has no solution for this?
==============================================
"In VisualStudio 2015 -> Tools -> Extensions and updates ->
Online: Search for the string: "Fix NuGet GetFullVsVersionString must be
called on the UI thread" and install the given fix."

I did it and found nothing.
Where is that extension to fix this issue?
Why did they remove it from marketplace?

0
Nikolay Mishev
Telerik team
answered on 02 Feb 2021, 04:16 PM

Hello Zakhaliya,

Thank you for contacting our support team. Would you please make sure you have the latest version of Progress Telerik Extension/s? You can check that out in Tools -> Extensions and Updates -> Updates.

If an update is available, please, update the extension and let me know if that resolves the problem.

Regards,
Nikolay Mishev
Progress Telerik

Virtual Classroom, the free self-paced technical training that gets you up to speed with Telerik and Kendo UI products quickly just got a fresh new look + new and improved content including a brand new Blazor course! Check it out at https://learn.telerik.com/.

0
Zakhaliya Ivarnovich
Top achievements
Rank 1
answered on 03 Feb 2021, 10:45 AM

Hi dear Admin,

I Uninstalled all telerik extensions and reinstalled them.

Problem is there still.

When i disable all telerik extensions error vanish.

So problem is from telerik extensions 100%. > But i do n't know which one!!!

I have Telerik ASP.Net - WinForms - MVC Extensions...

Please help me to fix this issue.

I really need those extensions.

 

==============================================

"In VisualStudio 2015 -> Tools -> Extensions and updates ->
Online: Search for the string: "Fix NuGet GetFullVsVersionString must be
called on the UI thread" and install the given fix."

I did it and found nothing.
Where is that extension to fix this issue?
Why did they remove it from marketplace?

Would you please create such that extension to fix this issue?

0
Vesko
Telerik team
answered on 05 Feb 2021, 10:23 AM

Hi Zakhaliya,

I have provided an answer in this forum thread.

Regards,
Vesko
Progress Telerik

Virtual Classroom, the free self-paced technical training that gets you up to speed with Telerik and Kendo UI products quickly just got a fresh new look + new and improved content including a brand new Blazor course! Check it out at https://learn.telerik.com/.

0
Zakhaliya Ivarnovich
Top achievements
Rank 1
answered on 05 Feb 2021, 11:27 AM

Thanks for the answer.

I attached log file on that thread.

Please check.

0
Cris RS
Top achievements
Rank 1
answered on 14 Apr 2021, 03:58 PM

Hello I'm facing the same issue.

I need to migrate 30 reports from an old App (Because old app has some code in Silverlight and the last version of VS to support it is VS2015) I'm using VS 2015 Enterprise Update 3 and Reporting R1 2021 SP2 (15.0.21.326).

If I don't use the Report Upgrade Wizard when opening this is shown:
Value cannot be null. Paramater name: Instance (In another thread points because is not using the current Telerik Tools)

So OK let's upgrade then this error:
GetFullVsVersionString must be called on the UI thread.

As Zakhaliya I tried all StackOverflow workarounds and none is working, The suggested extension fix (was removed long time ago)
installed/reinstalled/deleted the Nuget Package Manager and nothing is working

Because reports are inside a Project Library I need to open it inside VS2015.

0
Vesko
Telerik team
answered on 16 Apr 2021, 08:59 AM

Hi Cristian,

Am sorry to hear that. Did you try the workaround provided by Zakhaliya - disabling the Telerik extensions except the one for Reporting?

Regards,
Vesko
Progress Telerik

Тhe web is about to get a bit better! 

The Progress Hack-For-Good Challenge has started. Learn how to enter and make the web a worthier place: https://progress-worthyweb.devpost.com.

Tags
Installer and VS Extensions
Asked by
Steve
Top achievements
Rank 1
Answers by
Nikolay Mishev
Telerik team
Steve
Top achievements
Rank 1
Rob Ainscough
Top achievements
Rank 1
Zakhaliya Ivarnovich
Top achievements
Rank 1
Vesko
Telerik team
Cris RS
Top achievements
Rank 1
Share this question
or