This is a migrated thread and some comments may be shown as answers.

Full Screen Map

2 Answers 86 Views
Map
This is a migrated thread and some comments may be shown as answers.
Jason
Top achievements
Rank 1
Jason asked on 17 Feb 2017, 06:15 PM

Hello, I'm trying to make the kendo map full screen with the following CSS:

#map {
            top: 0;
            bottom: 0;
            left: 0;
            right: 0;
            height: 100%;
            position: absolute !important;
            z-index: 9;
            background-color: #ccc;
        }

 

But, when I zoom and slide the map around, I get "whitespace" on the sides that doesn't go away. I've attached a picture of what I see. 

Is there a better way of doing this? 

Thanks! 

2 Answers, 1 is accepted

Sort by
0
Accepted
Stefan
Telerik team
answered on 21 Feb 2017, 12:11 PM
Hello Jason,

I noticed that the undesired side effect occurs only when the Map is zoomed out on maximum as then the size is different. In this scenario, I can suggest setting the minZoom property to 2 as this will keep the Map on fullscreen:

http://docs.telerik.com/kendo-ui/api/javascript/dataviz/ui/map#configuration-minZoom

http://dojo.telerik.com/ulEzU

I hope this will help to achieve the desired result.

Regards,
Stefan
Telerik by Progress
Try our brand new, jQuery-free Angular 2 components built from ground-up which deliver the business app essential building blocks - a grid component, data (charts) and form elements.
0
Jason
Top achievements
Rank 1
answered on 23 Feb 2017, 05:34 PM

Thanks so much for the reply Stefan. I was using an older version of Kendo which was causing this issue. I have updated it to use the most recent release with which, like you, I don't this issue anymore.

Thanks again! -Jason

Tags
Map
Asked by
Jason
Top achievements
Rank 1
Answers by
Stefan
Telerik team
Jason
Top achievements
Rank 1
Share this question
or