This is a migrated thread and some comments may be shown as answers.

Floating panes jump(jerk) when moved

21 Answers 162 Views
Docking
This is a migrated thread and some comments may be shown as answers.
Peter Meinl
Top achievements
Rank 1
Peter Meinl asked on 15 Aug 2010, 06:03 PM
Floating panes doe not move smoothly when I move them around with the mouse. They jerk about 1cm at a time.
The complete WPF Window moves smoothly.

This problem only occurs on my desktop PC not on my far less powerful notebook.


Using: WPF40_2010_2_0812

21 Answers, 1 is accepted

Sort by
0
George
Telerik team
answered on 18 Aug 2010, 12:30 PM
Hello Peter Meinl,

Thank you for contacting us.

Could you please check our online demos and tell us if you suffer the same issue.
Here are the online demo for:

Looking forward to your reply.

Sincerely yours,
George
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
0
Peter Meinl
Top achievements
Rank 1
answered on 18 Aug 2010, 04:16 PM
The online demo hangs at 95.
0
George
Telerik team
answered on 19 Aug 2010, 11:54 AM
Hello Peter Meinl,

Please, clear your cache deleting all files and folders in "username\AppData\Local\Apps" directory.

Greetings,
George
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
0
Peter Meinl
Top achievements
Rank 1
answered on 19 Aug 2010, 09:44 PM
After clearing the cache the online demo loads fine. It works without problems. Floating windows move smoothly.

With your local WPF Docking demo floating windows do not move smoothly, they jump.
0
George
Telerik team
answered on 24 Aug 2010, 03:07 PM
Hello Peter Meinl,

Unfortunately, we could not reproduce the problem at our side. Could you please send us your PC and OS properties? Also a demo showing the problem will help us a lot to investigate the problem and provide you with a solution or more detailed instructions.

Looking forward to your reply.

Regards,
George
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
0
Peter Meinl
Top achievements
Rank 1
answered on 24 Aug 2010, 04:34 PM
I opened a support ticket 341690 to be able to send you the information requested.
0
Kevin
Top achievements
Rank 1
answered on 08 Nov 2010, 10:51 PM
You've probably solved this by now, but incase you haven't I thought I'd chime in. I saw really bad performance with dock pane dragging, grid rendering and even just scrolling through XAML files in VS 2010. I then discovered that the graphics chipset in my laptop is just not up to the task as far as hardware rendering goes. I added the following key to the registry:

HKEY_CURRENT_USER\Software\Microsoft\Avalon.Graphics\DisableHWAcceleration

It's a REG_DWORD and I set the value to 1 (to disable HW acceleration). The difference is dramatic. My laptop now works like the more powerful desktop computers that some of my co-workers are using. VS 2010 scrolling in XAML files was dramatically improved as well.

I know you said your desktop is the one having the trouble, but if you haven't resolved this I would say it's definitely worth a shot anyway. Just make sure you re-load whatever WPF applications you are experimenting with after changing this key.
0
Tom
Top achievements
Rank 1
answered on 01 Dec 2010, 07:39 PM
Hi

We are observing similar issues. On my Windows7 development machine, rendering performance of my app that uses Telerik docking is very poor - dragging around floating panes is very slow, and the animation of the compass is very slow as well. VS2010 docking works fine.

I tried the my app on an old XP laptop at home (a 5 year old cheap Dell), and the performance was far better. I find this really odd! Other colleagues in the office are seeing the same thing - all the old machines run the application ok, all the newer ones don't.

I updated the Nvidia drivers on my dev machine to the latest beta ones, and the situation is a bit better - I now perhaps get about 3 frames of animation per second when dragging, rather than 1 frame every 2 seconds, but it's certainly not acceptable performance for an application we would distribute.

The Telerik Demo app docking section works quite a lot better than my app - but I don't know why - my app is just an empty shell with some docking, the performance should be good.

Tom
0
Miroslav Nedyalkov
Telerik team
answered on 07 Dec 2010, 10:33 AM
Hi Everybody,

 Kevin, thank you for your suggestion - we will investigate this.

Tom, we are aware of performance problems with the Docking control and we are currently working on this. The odd thing here is that you are experiencing problems with Windows7 and not on XP, but we observe the opposite - on Windows7 everything is fine and on XP the performance is bad. Could you please share with us what is the resolution of you machines (both XP and W7)? Which demos do you try - browser hosted XBAP or desktop application? (you mentioned the performance is better in the demos) If you could send us the application that performs bad in a support thread this would help us investigate the issue.

Kind regards,
Miroslav Nedyalkov
the Telerik team
Browse the videos here>> to help you get started with RadControls for WPF
0
Tom
Top achievements
Rank 1
answered on 07 Dec 2010, 10:42 AM
Hi Miroslav

I made a support ticket submission for this on Friday, the ticket number is 372614. I attached a VS2010 solution. I hope to hear back soon. The screen resolution on my Win7 desktop is 1920x1200, on my old XP laptop it is 1280x1024. 

Thanks
Tom
0
Miroslav Nedyalkov
Telerik team
answered on 09 Dec 2010, 05:08 PM
Hello Tom,

 I tried your application - it works as fast as an empty Docking control (at least on my machine - Windows 7) - a little slow when on big screen resolution and placed inside a big Window. After switching off the animations, the performance became a little better. To switch off the animations you just need to set the AnimationManager.AnimationSelector attached property of the Docking control to Null.

Regards,
Miroslav Nedyalkov
the Telerik team
Browse the videos here>> to help you get started with RadControls for WPF
0
Pieter
Top achievements
Rank 2
answered on 07 Jan 2011, 08:23 PM
I got the same problem over here. Windows 7 Ultimate, 64 bit, Dell XPS M1730 4 GB, dual screen both at 1920 * 1200.
The WPF demo application has smooth floating panes.

The moment I start dragging one of the floating panes in my WPF (4.0) application using telerik RadControls_for_WPF35_2010_3_1110_Dev the processorload of one core goes to 100%, en de pane is jumping around a few times a second to catch up with the cursor.
I also tested version RadControls_for_WPF35_2010_3_1314_Dev, but this does not change the jumping behavior.

Because the content of the pane will be a more or less real time application this won't work if the processor core runs at 100% load. I hope Telerik can fix this problem soon.
0
david
Top achievements
Rank 1
answered on 10 Feb 2011, 04:21 PM
Is there already an answer for the jumping panes when dragging them across the desktop?
I have the same problem over here, when moving the dock-panel jumps to the new location
and the CPU load raises to 100%.

This is very important for my pilot software and is a show stopper if it not works.

David.
0
Miroslav Nedyalkov
Telerik team
answered on 15 Feb 2011, 04:08 PM
Hello Everybody,

 We are currently working on this matter. The new implementation should be ready before Q2 2011.

Best wishes,
Miroslav Nedyalkov
the Telerik team
Let us know about your Windows Phone 7 application built with RadControls and we will help you promote it. Learn more>>
0
Tom
Top achievements
Rank 1
answered on 17 Mar 2011, 04:07 PM
Telerik: Any news on progress with these issues?

Tom Davies
0
Miroslav Nedyalkov
Telerik team
answered on 17 Mar 2011, 04:11 PM
Hi Tom,

 This is still work in progress. We will do our best to drop some beta version of this at the end of April.

All the best,
Miroslav Nedyalkov
the Telerik team
0
Tom
Top achievements
Rank 1
answered on 17 Mar 2011, 05:25 PM
This is bad news :(

Tom Davies
0
Adam Marshall
Top achievements
Rank 1
answered on 05 Apr 2011, 09:38 PM
Hi,

I also am experiencing this issue. After performing numereous tests to try and track down what causes this, I believe it is related to the large Transparent FakeWindow the RadDocking control draws across all screens.

I found that the slowness of dragging the panes correlated to how many monitors were in use.

I disabled the multi monitors on a machine which was very slow, so only one was in use, and the dragging was smooth again.

So with one monitor, the dragging is acceptable.
With two monitors, (and a low spec machine) it is jerky.
With three monitors, the dragging is terrible.

Will this and the transparent window be sorted for the Q2 release?

Thank you,

Adam Marshall
0
Pete
Top achievements
Rank 1
answered on 08 Apr 2011, 03:30 AM
After reading all these posts I have to agree that the issue is definitely aggravated when multiple monitors are in play.  This is a serious issue for me as all of my users have multiple monitors, well in excess of 4, typically 6-8 monitors.  A typical trading floor environment.  I am relieved to see that Telerik expects a beta release this month and would certainly like to participate in testing.  Looking forward to this getting fixed...
0
George
Telerik team
answered on 11 Apr 2011, 10:05 AM
Hello,

Please, refer to the following forum thread - http://www.telerik.com/community/forums/wpf/docking/docking-fixed-in-new-release.aspx
 

Best wishes,
George
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
0
Gregory
Top achievements
Rank 1
answered on 26 May 2011, 10:04 PM
For what it's worth, we experienced the same behavior in our application. But we got it completely fixed when we disabled hardware graphics acceleration in our application. To do so, you just need to add the following code to your application class's Startup event handler:

RenderOptions.ProcessRenderMode = RenderMode.SoftwareOnly;

This should only disable GPU acceleration for the application, and leave it alone for everything else.
Tags
Docking
Asked by
Peter Meinl
Top achievements
Rank 1
Answers by
George
Telerik team
Peter Meinl
Top achievements
Rank 1
Kevin
Top achievements
Rank 1
Tom
Top achievements
Rank 1
Miroslav Nedyalkov
Telerik team
Pieter
Top achievements
Rank 2
david
Top achievements
Rank 1
Adam Marshall
Top achievements
Rank 1
Pete
Top achievements
Rank 1
Gregory
Top achievements
Rank 1
Share this question
or