This is a migrated thread and some comments may be shown as answers.
First Docked , then AutoHide
1 Answer 34 Views
This is a migrated thread and some comments may be shown as answers.
Falk Wegener
Top achievements
Rank 1
Falk Wegener asked on 13 Jun 2008, 12:59 PM
Hello,

I am using the DockingManager (6.0.2.0) and set two of the panels DockState-Property to AutoHide. Now the Designer cannot show the form anymore saying "This is not valid state for tabbed document container. Please first change state to Docked and then to AutoHide"

I did change the Designer Code and added the DockState-Property setting to my own Initialize method. But now every time I save the Form, the designer code gets altered back to AutoHide, which means after the next build again I cant see the from in the designer again.

Am I doing something wrong ? Whats the normal way of setting a Panel to AutoHide in the Designer.

Thanks

1 Answer, 1 is accepted

Sort by
0
Julian Benkov
Telerik team
answered on 16 Jun 2008, 07:45 AM
Hi Falk Wegener,

Thank you for writing.

Your DockPanel is attached to a TabbedDocument container and its state cannot be a AutoHide. Please first change the DockPanels to a Docked state like ToolWindow and then you can change the state to AutoHide.

The behavior is like Visual Studio Docking.

I hope this helps. If you have additional questions, please contact us.

Sincerely yours,
Julian Benkov
the Telerik team

Instantly find answers to your questions at the new Telerik Support Center
Tags
Dock
Asked by
Falk Wegener
Top achievements
Rank 1
Answers by
Julian Benkov
Telerik team
Share this question
or