This is a migrated thread and some comments may be shown as answers.

Fiddler2 - DefaultLan

9 Answers 77 Views
Telerik Trainer
This is a migrated thread and some comments may be shown as answers.
john
Top achievements
Rank 1
john asked on 09 Jan 2015, 10:32 PM
Greetings everyone,

My question regarding Fiddler two is regarding "DefaultLAN" which is addressed under "Tools" > "Connections" > "DefaultLAN". 

I Have been trying to toggle it on as it isnt possible at this moment due to the fact that its listed grey. (Can't toggle it on)
So far i havent been able to google whatsoever in my struggle to find a way to be able to toggle this option on. 
Could anyone tell me what is up with this and what i have to do to activate it?

Im sorry for this rookie question.

Regards

John M.

9 Answers, 1 is accepted

Sort by
0
Eric Lawrence
Telerik team
answered on 10 Jan 2015, 04:14 PM
Hi, John--

Can you explain more generally what problem you're trying to solve?

The "DefaultLAN" option is the default used by Fiddler. The only scenario in which it is not checked by default is if you've manually set a legacy registry key named "HookConnectionNamed" using the registry editor. 

Regards,
Eric Lawrence
Telerik
 

Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

 
0
john
Top achievements
Rank 1
answered on 11 Jan 2015, 09:39 PM
Hello,

Basically i want to toggle "defaultlan" on in the following screenshot : 
http://i57.tinypic.com/1z6utzp.jpg
I have tried to figure it all out and look it up on google but im far from experienced with these kinds of things, i just dont seem to be able to toggle it on.

Thanks for your reply
0
Eric Lawrence
Telerik team
answered on 12 Jan 2015, 03:23 PM
Hi, John--

I suspect the problem you're having here is that Fiddler isn't in "Capturing" mode. Is the "Capture traffic" box checked on the File menu? If so, can you please copy/paste the contents of Fiddler's Log tab?


Regards,
Eric Lawrence
Telerik
 

Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

 
0
Michael
Top achievements
Rank 1
answered on 13 Nov 2015, 05:03 PM

I have a similar issue where as when  start Fiddler thru IE , there is no traffic captured. I am using Fiddler 2 ( although I get the same results when I use Fiddler 4). Can someone tell me why Fiddler is not capturing or showing any traffic although I have cleared it and refreshed the browser window?

 

Thanks

0
Eric Lawrence
Telerik team
answered on 13 Nov 2015, 07:14 PM
Hi, Michael--

John's problem is that he had disabled capture in Fiddler (e.g. by unticking File > Capture traffic)... it's not clear to me whether you're saying that you've done the same thing? Have you tried another browser? Do you have any 3rd party networking software (e.g. a VPN) or security software (e.g. an antivirus program) installed?

Perhaps the most common support request is "Fiddler isn't capturing stuff. How do I fix this?"
 
To get help diagnosing the problem, please follow the following steps and report the results in your post:
 
   1. On Fiddler’s Help menu, click Troubleshoot... and navigate your browser somewhere. Does traffic appear in Fiddler?
   2. In your browser, visit http://ipv4.fiddler:8888/. Does anything appear in Fiddler or your browser?
   3. In your browser, visit http://localhost:8888/. Does anything appear in Fiddler or your browser?
 
Also, include information about what client you are attempting to use (e.g. Chrome), what URL you're attempting to load (or as much information about it as you can safely share, e.g. "A HTTPS URL on my Intranet"), and the Fiddler version number from Fiddler's Help About screen. Also, check Fiddler's LOG tab for any warning or error messages.
 
Thanks!
 
Note: If Fiddler isn't working with just one particular browser, check whether you have any browser extensions (e.g. "GeoSurf") installed that interfere with the browser's proxy settings.
 
Regards,
Eric Lawrence
Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
0
Michael
Top achievements
Rank 1
answered on 13 Nov 2015, 09:02 PM

Hello Eric. Thanks you for your response. I do have the Capture Selected. I am using Fiddler 2( I have used Fiddler 4 as well with the same results)usually connect to my work VPN using this laptop, but I am not connected when I have this issue. Either way Fiddler does not capture any traffic. I have try IE, Chrome and Firefox. Neither will produce any traffic.

 When I attempt to browse to http://ip4.fiddler:8888 , I get a " This Page can not be displayed". When I browse to http://localhost:8888, I get the following

 

Fiddler Echo Service
GET / HTTP/1.1 Accept: text/html, application/xhtml+xml, */* Referer: http://www.telerik.com/forums/fiddler2---defaultlan Accept-Language: en-US User-Agent: Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.1; WOW64; Trident/6.0) Accept-Encoding: gzip, deflate Host: localhost:8888 DNT: 1 Connection: Keep-Alive This page returned a HTTP/200 response
Originating Process Information: iexplore:3508

 

 With a 200 Connection Closed in Fiddler itself.

I am using Fiddler version 2.6.10.

Can  you please help me get this to work. I also disabled all the browser extentions.

0
Eric Lawrence
Telerik team
answered on 13 Nov 2015, 09:51 PM
Hello, Michael--

These symptoms indicate that Fiddler is reachable but your browsers aren't configured to send traffic to Fiddler. This most commonly occurs due to interference from corporate networking software (e.g. VPN clients, even while inactive) or antivirus software (e.g. TrendMicro, AVG, etc). These pieces of software sometimes unconditionally change the system's proxy settings away from Fiddler.  

While the "File > Capture Traffic" menu is checked in Fiddler, click the Tools > WinINET Options menu item. In the dialog box that appears, click the LAN Settings button; what do you see?

In Firefox, if you adjust the settings as shown in the "manually configure Firefox" section of this post: http://www.telerik.com/blogs/configuring-firefox-for-fiddler (specifically http://www.telerik.com/sfimages/default-source/blogs/24windows-live-writer-configuring-firefox_990c-image_5-png-png), does Firefox traffic begin to appear in Fiddler?

Regards,
Eric Lawrence
Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
0
Michael
Top achievements
Rank 1
answered on 14 Nov 2015, 05:33 PM

 Hello Eric,
 Thank you once again for your response. I am able to get Firefox to work with Fiddler. It still does not capture any IE traffic. I understand what you are saying about the configuration with the VPN and proxy setting of the system.

To answer your question about the WININet options:

While the "File > Capture Traffic" menu is checked in Fiddler, click the Tools > WinINET Options menu item. In the dialog box that appears, click the LAN Settings button; what do you see?


 The LAN Settings window os empty. There is nothing selected.

In addition, I have a request or maybe the tool already does have this. Can you add the time to the Web Session Window/ Panel so that we can see when the sessions start and end? I understand that we can see that in the properties window when selected, but I think it would be a great feature to be able to see the time stamps in the Web Sesson window.
What do you think?

 Thanks

Michael

0
Eric Lawrence
Telerik team
answered on 16 Nov 2015, 07:36 PM
Hi, Michael--

If the LAN Settings box is empty, that means that either the attempt to set the proxy failed due to an API error, or that something changed the proxy settings away from Fiddler. Does Fiddler's LOG tab show anything when you hit F12 over and over to attach/detach Fiddler as the system's default proxy?

You can show any timestamp you like in the Web Sessions list as a column. Right-click the list header and choose "Customize columns...". In the box that appears, select the Session Timers collection.
 
Regards,
Eric Lawrence
Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Tags
Telerik Trainer
Asked by
john
Top achievements
Rank 1
Answers by
Eric Lawrence
Telerik team
john
Top achievements
Rank 1
Michael
Top achievements
Rank 1
Share this question
or