Exception when panning/zooming

Thread is closed for posting
3 posts, 0 answers
  1. Chris
    Chris avatar
    11 posts
    Member since:
    Aug 2011

    Posted 31 Oct 2013 Link to this post

    This issue seems to be new to the 913 release of RadControls as it was working fine for my situation previously.

    I basically have a page with a pivot, with several pivotitems. On one of the pivot items is an image. When the user double taps the image, I do the following:

    Hide the ApplicationBar
    Create a new instance of MY user control called PanScanImage, which basically has a Source property, and wraps the PanAndZoomImage control (it has a XAML which is a grid that fills the page, and it literaly just sets the Source property on that control).
    Creates an instance of the DialogService (from the Coding4Fun toolkit), and uses my user control as the child.
    I then display the dialog (its a popup basically).
    Up until this point works fine.
    Then when you try and pan/zoom I get this exception:

        base: {System.Windows.ApplicationUnhandledExceptionEventArgs}
        ExceptionObject: {System.NullReferenceException: Object reference not set to an instance of an object.
       at Telerik.Windows.Controls.SlideView.PanAndZoomImage.Telerik.Windows.Controls.Gestures.IPinchListener.OnPinch(PinchGesture gesture)
       at Telerik.Windows.Controls.PinchProcessor.OnFrameReported(Object sender, TouchFrameEventArgs e)
       at System.Windows.Input.Touch.OnTouch(Object sender, TouchFrameEventArgs e)
       at MS.Internal.JoltHelper.RaiseEvent(IntPtr target, UInt32 eventId, IntPtr coreEventArgs, UInt32 eventArgsTypeIndex)}
        Handled: false

    This scenario used to work prior to 913...

    EDIT: Just to confirm, it was build 828 that this worked in.
  2. Todor
    Todor avatar
    798 posts

    Posted 01 Nov 2013 Link to this post

    Hi Chris,

    Thank you for writing.

    I have responded to your support ticket regarding the same issue.

    In short, it is fixed with the Q3 release, so you simply need to download the latest version of our controls.

    Let us know if you need further assistance.

    Have a suggestion or face a problem - you can use the Ideas & Feedback portal to submit ideas, feedback and vote for them.
  3. Chris
    Chris avatar
    11 posts
    Member since:
    Aug 2011

    Posted 01 Nov 2013 Link to this post

    Happy to confirm that it has fixed it. Not sure why but the Q3 release wasn't showing up in the updates. Downloaded+installed manually and all is well. Thank you.
Back to Top