Error from kendo MVVM on bind in 2012.2.913 and up (have tried latest 2013.1.514)

2 posts, 0 answers
  1. Scott
    Scott avatar
    14 posts
    Member since:
    Oct 2012

    Posted 02 Jul 2013 Link to this post

    The following fiddle shows an error I am receiving from Kendo when binding with MVVM:

    This fiddle is running on kendoUI 2012.2.913 and is the first appearance of the problem.  I have tried all the way up to current and the problem is the same throughout all the versions.

    In the fiddle, click on an item in the grid shown in the running app.  Change the value 'Row1' to some other text.  Click the 'Save' button.  View the console and see:

    Uncaught TypeError: Cannot call method 'bind' of undefined kendo.all.min.js:22

    This worked fine with kendo 2012.2.710  as seen in this fiddle:

    I've been chasing this in my app for quite a lot of time now, nice to finally find that it did work at some point, how can I fix it?

  2. Alexander Valchev
    Alexander Valchev avatar
    2895 posts

    Posted 04 Jul 2013 Link to this post

    Hi Scott,

    I already replied in the other forum thread which you submitted on a similar problem. It seems that the issue is caused by multiple rebinding of the content. Please try to avoid the multiple execution of kendo.bind by following the approach used in the examples which I provided.

    Alexander Valchev
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
Back to Top