This is a migrated thread and some comments may be shown as answers.

EntryPointNotFoundException !

5 Answers 203 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
This question is locked. New answers and comments are not allowed.
Jean-Yves
Top achievements
Rank 1
Jean-Yves asked on 14 Jun 2012, 05:30 PM
Hi,

I'm trying Kendo UI for ASP.NET MVC on a MVC 4 project.
But I get an error at the end of your introduction (http://www.kendoui.com/documentation/asp-net-mvc/introduction.aspx)


When I put the 
@(Html.Kendo().DatePicker().Name("Birthday"))

My MVC project stop with this exception : System.EntryPointNotFoundException  


The wired thing is that with 
@(Html.Kendo().Calendar()
        .Name("calendar")
        .Min(new DateTime(2010, 1, 1, 10, 0, 0))
        .Max(new DateTime(2015, 1, 1, 20, 0, 0))
        .Value(DateTime.Now)
        )
I don't get any error!


Do you have any idea about this issue?
I'm missing something?

Thank you

5 Answers, 1 is accepted

Sort by
0
Iliana Nikolova
Telerik team
answered on 15 Jun 2012, 07:28 AM
Hi Jean,

I am not sure what causes the problem in your application. Could you please provide a sample project that could be examined in details? This way I will be able to observe the problem and advice you further. Thank you in advance.

 

Regards,
Iliana Nikolova
the Telerik team
Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
0
Jean-Yves
Top achievements
Rank 1
answered on 15 Jun 2012, 03:03 PM
Hello, 

Of course i can provide you a sample.

Here it is:http://dl.free.fr/kcLLr211S

Let me know :)

For information I'm on Windows 8 with VS Premium 2012 RC
0
Jean-Yves
Top achievements
Rank 1
answered on 15 Jun 2012, 03:23 PM
Re Hello!

I found something!!! (I was thinking about it all day!)
I think it was a compatibility issue.

Yes, I just tried with an MVC 3 project and It's working perfectly.

So I add this (in the main web.config)
<runtime>
  <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
    <dependentAssembly>
      <assemblyIdentity name="System.Web.Mvc" publicKeyToken="31BF3856AD364E35" />
      <bindingRedirect oldVersion="1.0.0.0-3.0.0.0" newVersion="4.0.0.0" />
    </dependentAssembly>
  </assemblyBinding>
</runtime>

And now It's working in my MVC4 project!!!
0
Mika
Top achievements
Rank 1
answered on 18 Jun 2012, 09:28 PM
Thanks Jean-Yves.

I had similar problem with menu. It was giving me an error:

System.ArgumentOutOfRangeException was unhandled by user code
Message=Index was
out of range. Must be non-negative and less than the size of the collection.
Parameter name: index

with code:
@(Html.Kendo().Menu()
     .Name("menu") //The name of the menu is mandatory. It specifies the "id" attribute of the widget.
     .Items(items =>
     {
         items.Add().Text("Item 1"); //Add item with text "Item1")
         items.Add().Text("Item 2"); //Add item with text "Item2")
     })
 )

... but this bindingRedirect helps also in this case. 

I've got VS 2010 SP1 + MVC 4 RC
0
Eric
Top achievements
Rank 1
answered on 14 Jul 2012, 10:49 PM
I thought this was corrected after reading this post, but unfortunately not.  In my case there was already an assembly redirect and it still fails with the same error.  Any other ideas?  I'm hoping I don't have to revise my project to MVC 3, that will be a big pain.

UPDATE: Sorry looks like it was my own bone-headed move where I had messed up a redirect further up in the chain and the MVC redirect wasn't being applied. 

I probably never would have figured out my root issue without this post, so I'd like to thank Jean-Yves and suggest he get some "Telerik Points" for figuring this one out.

Thanks!

Eric S.
Tags
General Discussions
Asked by
Jean-Yves
Top achievements
Rank 1
Answers by
Iliana Nikolova
Telerik team
Jean-Yves
Top achievements
Rank 1
Mika
Top achievements
Rank 1
Eric
Top achievements
Rank 1
Share this question
or