This is a migrated thread and some comments may be shown as answers.

Editor - Undo with Immutables not working in Internet Explorer

1 Answer 27 Views
Editor
This is a migrated thread and some comments may be shown as answers.
Ruairi
Top achievements
Rank 1
Ruairi asked on 13 Feb 2017, 12:42 PM

I'm using the Editor and the Immutables functionality.

When I'm editing a document in the Editor that contains Immutables in Internet Explorer and I 'Undo' (Ctrl + Z) something the formatting of the immutable content is messed up or disappears completely.This works fine in Chrome but not in Internet Explorer.

If you want to test use this Kendo demo in Internet Explorer

http://demos.telerik.com/kendo-ui/editor/immutable-elements

Now select some text in the example and Bold it using the editor bold command. Now undo (Ctrl + z). The Immutable fields disappear!!

Any help appreciated Telerik

 

1 Answer, 1 is accepted

Sort by
0
Nencho
Telerik team
answered on 15 Feb 2017, 11:26 AM
Hello Tyler,

I was able to replicate the described issue and I can confirm that the problematic behavior is a bug, which is already logged in our github repo:

https://github.com/telerik/kendo-ui-core/issues/2780


In addition, I have updated your Telerik Points for reporting for that problem.

Regards,
Nencho
Telerik by Progress
Try our brand new, jQuery-free Angular 2 components built from ground-up which deliver the business app essential building blocks - a grid component, data visualization (charts) and form elements.
Tags
Editor
Asked by
Ruairi
Top achievements
Rank 1
Answers by
Nencho
Telerik team
Share this question
or