This is a migrated thread and some comments may be shown as answers.

Download freezes before completion

8 Answers 91 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Clint
Top achievements
Rank 1
Clint asked on 01 Jun 2017, 01:10 AM

I have been attempting to download UI for Winforms R1 2017 SP1 for the past couple of days, but every time I start the download using the Control Panel it gets to 152/162MB and then stops.  After about another hour or so of waiting I eventually get a warning that the Hash doesnt match.  The first time it failed, I chose the retry option and the result was the same. So at the end of the second failure, I chose the cancel option at which point the progress bar on the control panel updated and displayed 2998MB/162MB.  I gave up and tried again today, but it appears to be doing the same thing.

 

Is there another way that I can download manually that particular version of the controls without using the control panel and install the version and maintain my current version of the controls which I need to do to support an application already in production.

8 Answers, 1 is accepted

Sort by
0
Nikola
Telerik team
answered on 01 Jun 2017, 10:59 AM
Hello Clint,

I am sorry to hear of the difficulties you encountered installing our product. 

You could download the offline (msi) installer from Your Account and use it to install the controls you need. The following steps would help you do that:

1. Log in into your Telerik account
2. Click on the Downloads tab
4. Select the product you want to install
5. Choose the desired version in the Version drop down
6. Download the stand alone installer (msi file)
7. Follow the installation steps

The Control Panel is actually doing the same thing and the issues you describe could be caused by unavailability of the CDN that the file is stored at or other network related issues. What you could try is install one of the other products and lets us know whether the same behavior is observed.

I am looking forward to your answer.

Regards,
Nikola
Progress Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
0
Michael
Top achievements
Rank 1
answered on 29 Aug 2017, 01:25 AM

I've been experiencing the same problems for a couple months. Probably first encountered around June. Just tried again as setting up new Dev machine. I have 2 different licenses and accounts for 2 different companies and use different development machines that have different configs and policies. Installing any component via Telerik Control Panel always hangs in the download phase. Also, cancelling hangs the Telerik control panel as well. 

 

I've successfully downloaded the MSIs and installed directly, but really liked using the Telerik control panel. I hope this is worked out sometime soon.

 

TelerikControlPanelSetup_2017_3_0814_1

 

0
Dyanko
Telerik team
answered on 29 Aug 2017, 06:12 AM
Hello Michael,

Thank you for reaching us.

Would you please check with your Administrator if any download size restrictions exist on your Network infrastructure? Does the Telerik Control Panel hang at the same download size? I would also suggest to install a Telerik products one by one and check if the problem still exists.

Looking forward to your reply.

Regards,
Dyanko
Progress Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
0
Michael
Top achievements
Rank 1
answered on 29 Aug 2017, 06:34 AM
Encounter the same problem on two different devicesfrom different companies. Use on different networks and have different security policy. Neither has download size limit. And I was able to directly download and install the MSI's without issue. Yes, it stops at the same location.
0
Dyanko
Telerik team
answered on 29 Aug 2017, 06:40 AM
Hello Michael,

Thank you for confirming.

Which product you are trying to install when the Telerik Control Panel hangs? A screenshot during the installation would be helpful as well.

Regards,
Dyanko
Progress Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
0
Michael
Top achievements
Rank 1
answered on 29 Aug 2017, 06:49 AM

I was attempting to install: UI for WPF, Reporting, & JustMock. 

 

Don't remember which one it hung on, stopped around 75MB. Last time was trying to install the three above as well as a few more. It hung later, but same results. Last time after I canceled (and the control panel hung when trying to cancel as well) I later tried just one, probably the WPF or Reporting. It failed as well so I downloaded the MSI directly and installed individually.

Both laptops are Win 10 x64 Enterprise. One is 1703 and the other 1607. The 1607 is configured for FIPS compliance. The 1703 is not.

I've moved on installing the MSIs directly. Running the control panel to try to install the same selections again just for a screen capture to show progress stopped around 75MB would require a lot of effort for what seems like minimal info.

 

0
Michael
Top achievements
Rank 1
answered on 29 Aug 2017, 06:53 AM

Device 1: Win 10 x64 Enterprise, 1607, enterprise secure config, disk-level OVA/M encryption, and FIPS validation enabled

Device 1: Win 10 x64 Enterprise,1703, non-FIPS

 

I've moved on. Screen capture would just show you it stops around 75MB and would require me to uninstall the MSIs I downloaded directly and installed.  

0
Dyanko
Telerik team
answered on 30 Aug 2017, 12:52 PM
Hi Michael,

I have checked the Telerik Control Panel behavior when FIPS is enabled. I confirm that it hangs and this is expected. The following article explains why the application behaves in such manner: https://blogs.technet.microsoft.com/secguide/2014/04/07/why-were-not-recommending-fips-mode-anymore/

I would suggest to disable the FIPS and give it another try. The following steps will help you to achieve that:
  1. Open the 'Run' menu by pressing the combination 'Windows Key + R'.
  2. Type 'secpol.msc' and press 'Enter' or click the 'Ok' button.
  3. In the Local Security Policy management console window that opens, use the left tab to navigate to the Local Policies -> Security Options.
  4. Scroll down the right pane and double-click 'System cryptography: Use FIPS compliant algorithms for encryption, hashing, and signing'.
  5. In the properties window, select the 'Disabled' option and click the 'Apply' button.

Please let us know if the issue still occurs.

Regards,
Dyanko
Progress Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Tags
General Discussions
Asked by
Clint
Top achievements
Rank 1
Answers by
Nikola
Telerik team
Michael
Top achievements
Rank 1
Dyanko
Telerik team
Share this question
or