This is a migrated thread and some comments may be shown as answers.

Disabled timeline in Scheduler

1 Answer 27 Views
Scheduler and Reminder
This is a migrated thread and some comments may be shown as answers.
Dave Mortgatta
Top achievements
Rank 1
Dave Mortgatta asked on 11 Apr 2012, 07:31 PM
I am trying to disable timeline completely from showing to user in Dayview and weekly view. Please help.

1 Answer, 1 is accepted

Sort by
0
Ivan Todorov
Telerik team
answered on 12 Apr 2012, 04:01 PM
Hello Dave,

Thank you for contacting us.

You can achieve this by setting the ShowRuler property of the ActiveView to false. You can do this only if the ActiveView is DayView or WeekView since these are the only views that have a ruler. Here is a sample code:
//if the active view is DayView:
this.radScheduler1.GetDayView().ShowRuler = false;
 
//if the active view is WeekView
this.radScheduler1.GetWeekView().ShowRuler = false;

Additionally, if you are changing views via the RadSchedulerNavigator or in some other way, you might need to handle the ActiveViewChanged event of RadScheduler and disable the ruler in the new views:
void radScheduler1_ActiveViewChanged(object sender, Telerik.WinControls.UI.SchedulerViewChangedEventArgs e)
{
    if (this.radScheduler1.GetDayView() != null)
    {
        this.radScheduler1.GetDayView().ShowRuler = false;
    }
 
    if (this.radScheduler1.GetWeekView() != null)
    {
        this.radScheduler1.GetWeekView().ShowRuler = false;
    }
}

More information about different view settings can be found in our online documentation.

I hope this will help you. Do not hesitate to ask if you have any additional questions.

Kind regards,
Ivan Todorov
the Telerik team
RadControls for WinForms Q1'12 release is now live! Check out what's new or download a free trial >>
Tags
Scheduler and Reminder
Asked by
Dave Mortgatta
Top achievements
Rank 1
Answers by
Ivan Todorov
Telerik team
Share this question
or