This is a migrated thread and some comments may be shown as answers.

Disable scrolling in Backstage

2 Answers 32 Views
RibbonView and RibbonWindow
This is a migrated thread and some comments may be shown as answers.
Geoffrey
Top achievements
Rank 1
Geoffrey asked on 23 Dec 2015, 10:04 AM
Hi,

I try to disable scrolling in RadRibbonBackstage.

I know that changing ControlTemplate and deleting Scrollviewer works.

But this solution is not compatible with switching theme at runtime.

Please, is there any solution ?

Best regards,
Geoffrey
 

2 Answers, 1 is accepted

Sort by
0
Martin Ivanov
Telerik team
answered on 25 Dec 2015, 08:00 AM
Hello Geoffrey,

You can achieve your requirement by setting the ScrollViewer.VerticalScrollBarVisibility attached property on the backstage to Disabled. This will hide the scrollbar even if there are items out of the viewport.
<telerik:RadRibbonBackstage ScrollViewer.VerticalScrollBarVisibility="Disabled">

I hope this approach works for you.

Regards,
Martin
Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
0
Geoffrey
Top achievements
Rank 1
answered on 28 Dec 2015, 08:02 AM
Hello,

Thanks for your answer, it works great :-)
Tags
RibbonView and RibbonWindow
Asked by
Geoffrey
Top achievements
Rank 1
Answers by
Martin Ivanov
Telerik team
Geoffrey
Top achievements
Rank 1
Share this question
or