Column resize in Edit Mode

3 posts, 0 answers
  1. Kevin
    Kevin avatar
    22 posts
    Member since:
    Feb 2014

    Posted 05 Mar 2014 Link to this post

    When entering Edit mode (either In Line or Batch) the columns of the grid are automatically resizing.  Is there any way to get them to stay at the static width they appear in when in read only mode?
  2. Dimo
    Admin
    Dimo avatar
    8475 posts

    Posted 05 Mar 2014 Link to this post

    Hello Kevin,

    Yes, set a table-layout:fixed style to the Grid table or enable Grid scrolling, which will apply the style internally, as it is required then.

    http://docs.telerik.com/kendo-ui/getting-started/web/grid/walkthrough#column-widths

    Regards,
    Dimo
    Telerik

    DevCraft Q1'14 is here! Join the free online conference to see how this release solves your top-5 .NET challenges. Reserve your seat now!

  3. Kevin
    Kevin avatar
    22 posts
    Member since:
    Feb 2014

    Posted 05 Mar 2014 Link to this post

    Hi Dimo,

    Thanks for the quick reply! I had hoped to avoid a fixed table layout since it makes every column a uniform width, but I'll give enabling scrolling a try as an alternative.

    Thanks,
    Kevin
Back to Top