Can install on device

Thread is closed for posting
5 posts, 0 answers
  1. Mike
    Mike avatar
    1 posts
    Member since:
    Mar 2015

    Posted 05 Mar 2015 Link to this post


    Looks like I'm the first one to post! Anyhow I was running through the demo app of creating a photo gallery and when I tried to build the app and install it I ran into a few issues

    1) The companion app crashed, I was able to resolve this by uninstalling and re-installing ( I'm on HTC m8 android 4.4 ) 
    2) Once in the app I 'tapped' the button in the header bar to sync or scan and got an error message 

    Error: Invalid url" ". Url must start with prefix: 'nativescript:'. 

    So I figured I would just use the URL, so I copied the URL and pasted it into an email and sent it to my phone. When I clicked on the URL it opened the nativescript companion app but did nothing.

  2. Todd
    Todd avatar
    7 posts
    Member since:
    Jun 2012

    Posted 05 Mar 2015 in reply to Mike Link to this post

    Hi Mike!

    Sorry to hear you're having trouble getting started. Let's try to figure it out.

    First, just to double-check, make sure you're working through the NativeScript Photo Album tutorial. There are Photo Album tutorials in AppBuilder for both Hybrid and NativeScript projects, so you want to be sure you're working on the NativeScript version.

    You can verify this by looking at the tutorial progress bar ("Build a photo album"). Under the tutorial name, you should see "NATIVESCRIPT."

    You can also verify you're working in a NativeScript AppBuilder project by double-clicking the "Properties" item in your file explorer and checking for the "NativeScript Version" drop down on the first properties screen. If you see "Cordova Version" instead, you've accidentally landed in a Hybrid AppBuilder project.

    Assuming all that checks-out, the next potential snag is that you need to have both the AppBuilder and NativeScript companion apps installed on your device (at least for iOS...don't have my HTC M8 handy to double-check on Android). If you only have the NativeScript companion app installed, try also installing the AppBuilder companion app.

    Google Play:

    Hope some of this helps.
  3. Carlos
    Carlos avatar
    4 posts
    Member since:
    Feb 2014

    Posted 20 Mar 2015 in reply to Todd Link to this post

    Hey Tererik guys. I am getting the same issue.  The NativeScript companion app launches, but when you try to use the scan QR code feature from the Android notifications and scan the QR code for my NativeScript project, I get the same message as the first commenter here.  Gives an error and states the URL must start with prefix NativeScript. Any ideas?
  4. Carlos
    Carlos avatar
    4 posts
    Member since:
    Feb 2014

    Posted 20 Mar 2015 Link to this post

    Should mention I am running Android 5.0 on a Moto X 2nd Generation.  Don't know if that helps
  5. Carlos
    Carlos avatar
    4 posts
    Member since:
    Feb 2014

    Posted 20 Mar 2015 Link to this post

    So I found out what MY problem was. I was trying to scan the App Package QR code with the NativeScript app.  Not an 3rd party QRCode app.  That may be the original posters' issue too.  Must be built using the NativeScript companion app option.  Slight oversight on my part.
Back to Top