build error for ios

Thread is closed for posting
4 posts, 0 answers
  1. Michael
    Michael avatar
    151 posts
    Member since:
    Jan 2012

    Posted 13 Nov 2013 Link to this post

    Started getting this error recently when I attempt to build/deploy onto an ios device. The program still auto-updates on the device when I save it, though. Wondering what it means, exactly?

    Error: ENOENT, no such file or directory '/Users/builder/Cordova/Cordova270/CorePlugins/org.apache.cordova.core.device/plugin.xml' at Object.fs.openSync (fs.js:427:18) at Object.fs.readFileSync (fs.js:284:15) at Object.module.exports.parseElementtreeSync (/Users/builder/Cordova/node_modules/plugman/src/util/xml-helpers.js:107:27) at Object.fetchPlugin [as fetch] (/Users/builder/Cordova/node_modules/plugman/src/fetch.js:26:31) at possiblyFetch (/Users/builder/Cordova/node_modules/plugman/src/install.js:29:31) at Object.installPlugin [as install] (/Users/builder/Cordova/node_modules/plugman/src/install.js:19:5) at Object. (/Users/builder/Cordova/node_modules/plugman/main.js:77:13) at Module._compile (module.js:456:26) at Object.Module._extensions..js (module.js:474:10) at Module.load (module.js:356:32) N/A [MyAppName] 0 0 C# N/A
  2. Michael
    Michael avatar
    151 posts
    Member since:
    Jan 2012

    Posted 13 Nov 2013 Link to this post

    I switched to cardova 3, attempted to build and deploy and it failed. the log said:

    Exception rethrown at [0]: 
       at System.Runtime.CompilerServices.AsyncMethodBuilderCore.<ThrowAsync>b__0(Object state)
       at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
       at MS.Internal.Threading.ExceptionFilterHelper.TryCatchWhen(Object source, Delegate method, Object args, Int32 numArgs, Delegate catchHandler)

    Then I switched back to cardova 2.7, attempted to build and deploy and both errors went away.

    Not sure what that means. Glad it is fixed, in any case.
  3. Pete
    Pete avatar
    18 posts
    Member since:
    Apr 2013

    Posted 13 Nov 2013 Link to this post

    I got this error a couple times when trying to migrate to Cordova.  The first time I started a new project, and copied all of my files over.  (Pain in the butt.)  But it worked.

    Then I needed to reset my app to an older version (with 2.7 Cordova) (since we don't have branch support yet!) for some bug fixes.  I then tried a second transition.  Got the error, switched back to Cordova 2.7 in the selector, and then switched to Cordova 3.0 again in the selector (no code chages), and the second time I switched it worked correctly.  The migration script (for me at least) isn't 100%, but if you make the switch a couple times it may make it all the way through correctly.
  4. Steve
    Steve avatar
    10941 posts

    Posted 14 Nov 2013 Link to this post

    Hi guys,

    This is an upgrade bug in our latest release that could be avoided fairly easy following these steps:

    1. Go to Project Properties -> Plugins
    2. Enable and Disable any of our Advanced Plugins
    3. Save

    After that you should be able to build & deploy successfully.

    This workaround will cause a change in your project file. It should have empty CorePlugins like this:


    When you are using Cordova 2.7 the CorePlugins property should be empty. We suspect that you have tried to upgrade to 3.0 in earlier Icenium release, but for some reason you have downgraded to 3.0. This procedure has added the CorePlugins tag which is breaking the things for Cordova 2.7.

    Sorry for the temporary inconvenience.

    You've missed the Icenium Visual Studio Integration keynote? It has been recorded and posted here.
    Looking for tips & tricks directly from the Icenium team? Check out our blog!
    Share feedback and vote for features on our Feedback Portal.
Back to Top