Batch Grid Chrome Tab Key Issue

5 posts, 1 answers
  1. Brandon
    Brandon avatar
    17 posts
    Member since:
    Sep 2011

    Posted 03 Feb 2016 Link to this post

    I'm working with the Kendo UI batch editor in Chrome. When a user hits the tab key to navigate to the next cell, the page is hijacked and automatically does a page down action to scroll down the page.

    This can be very frustrating for our Chrome users. It does not happen in Internet Explorer 11.

     

    The undesired functionality can be reproduced in the batch editing example here:

    http://demos.telerik.com/kendo-ui/grid/editing

     

    Any ideas on how I can prevent this from happening?

  2. Nikolay Rusev
    Admin
    Nikolay Rusev avatar
    2289 posts

    Posted 08 Feb 2016 Link to this post

    Hello Brandon,

     

    We are not sure what you mean by this `the page is hijacked and automatically does a page down action to scroll down the page`. Can you please elaborate a bit more?

     

    When keyboard navigataion, i.e navigatable: true, is enabled for the Grid it handles certain keys like page up/down to change current page and persist focused state inside the widget. If this is what you mean by the above statement it is expected. You can disabled it by setting navigatable options to false in widget configuration.

     

    Regards,
    Nikolay Rusev
    Telerik
     
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
     
  3. Brandon
    Brandon avatar
    17 posts
    Member since:
    Sep 2011

    Posted 08 Feb 2016 in reply to Nikolay Rusev Link to this post

    I linked two video examples below. The chrome video has the page down issue when I tab, but the IE 11 version does not have the issue.Let me know if there is a preferred method of sending you a video example.

    Chrome example: https://vid.me/e/6NSe

    IE11 example: https://vid.me/e/Sm9H

  4. Answer
    Nikolay Rusev
    Admin
    Nikolay Rusev avatar
    2289 posts

    Posted 10 Feb 2016 Link to this post

    Hello Brandon,

     

    I see what you mean now. This behavior is also caused due to navigatable feature. The reason for it is that the Grid table is the focusable element and when it receives focus the browser performs scroll into view action. There isn't a way to prevent this browser behavior.

     

    For IE, where applicable, we are using setActive method instead. It does essentially the same as calling focus, but without the scroll into view part. This is the reason for seeing difference in the browsers.

     

    Unfortunately the only thing we can suggest, if you don't like the current behavior, is to disable built-in keyboard navigation and have own implementation for it.

     

    Regards,
    Nikolay Rusev
    Telerik
     
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
     
  5. Brandon
    Brandon avatar
    17 posts
    Member since:
    Sep 2011

    Posted 10 Feb 2016 Link to this post

    Thank you for the suggestion Nikolay.

    We will force our users to use IE for this release and consider adding our own implementation after we go live.

Back to Top