This is a migrated thread and some comments may be shown as answers.
Avoid hyperlink creation in internet explorer
3 Answers 15 Views
This is a migrated thread and some comments may be shown as answers.
Yuvraj
Top achievements
Rank 1
Yuvraj asked on 19 Jul 2016, 06:00 AM

It is found that all browsers except IE do not auto convert text into hyperlink. eg. abc@xyz.com is auto created to a link - <a href="mailto:abc@xyz.com">abc@xyz.com</a> in IE

 

I want to know what is the way to avoid hyperlink creation in IE.

3 Answers, 1 is accepted

Sort by
0
Stanimir
Telerik team
answered on 20 Jul 2016, 05:57 AM
Hello,

Thank you for contacting us.

Information of how to disable this IE feature can be found in the following stack overflow article: http://stackoverflow.com/questions/3519665/disable-automatic-url-detection-for-elements-with-contenteditable-flag-in-ie/7568958#7568958

I hope this helps.

Regards,
Stanimir
Telerik by Progress
 
Get started with Kendo UI in days. Online training courses help you quickly implement components into your apps.
 
0
Wes
Top achievements
Rank 1
answered on 15 Dec 2016, 08:45 PM
As noted in the stackoverflow article, that solution doesn't work in IE11.
0
Rumen
Telerik team
answered on 19 Dec 2016, 12:01 PM

Hi Wes,

It appeared that Internet Explorer 11 does not support the AutoUrlDetect property of the execCommand method as one can see in this MSDN article: Commands A-C and this is regression.

Since the auto URL creation functionality is entirely controlled by the browser (IE), it is up to the browser developers to provide an option to enable/disable it for the editable content area elements such as the content area of Kendo Editor.

Best regards,

Rumen
Telerik by Progress
Try our brand new, jQuery-free Angular 2 components built from ground-up which deliver the business app essential building blocks - a grid component, data visualization (charts) and form elements.
Asked by
Yuvraj
Top achievements
Rank 1
Answers by
Stanimir
Telerik team
Wes
Top achievements
Rank 1
Rumen
Telerik team
Share this question
or