Appointments 30mins or less

5 posts, 1 answers
  1. Marcus
    Marcus avatar
    5 posts
    Member since:
    Sep 2012

    Posted 25 Aug 2009 Link to this post

    I'm trying out the scheduler component, and I will need to default to having appointments as multiples of 30 minutes.

    The way I think I should be doing this is
    SchedulerDayView view = radScheduler1.GetDayView(); 
    view.RangeFactor = ScaleRange.HalfHour; 

    But when I do that, and then try to create appointments, the start and finish time boxes are greyed out and the appointments always end up being all day appointments.

    I am using a custom Appointment type and custom EditAppointmentDialog, but everything is working fine for me until I set the RangeFactor.

    I'm using 2009 Q2 SP1.

    Can anyone give me any hints as to why this would not work?

    Thanks,

    Marcus.
  2. Marcus
    Marcus avatar
    5 posts
    Member since:
    Sep 2012

    Posted 26 Aug 2009 Link to this post

    This appears to be a bug in the Telerik Scheduler, as the same problem exists in the demo application that comes with the tools.  Doh!

    It works OK as long as the appointments are at least an hour, so it's probably not to do with the ScaleRange, but appointment duration.

    Is this a known bug?

    Does anyone know if this is going to be fixed some time soon?

    Thanks,

    Marcus.
  3. Answer
    Boyko Markov
    Admin
    Boyko Markov avatar
    610 posts

    Posted 28 Aug 2009 Link to this post

    Hello Marcus,

    Thank you for reporting this issue - your feedback was really helpful. We have been able to reproduce it and we will fix it for the next major release of our toolkit.

    Please write us back if you need more information.


    Greetings,
    Boyko Markov
    the Telerik team
    P.S. I have updated your Telerik points.

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  4. Jeremy Murtishaw
    Jeremy Murtishaw avatar
    86 posts
    Member since:
    Apr 2009

    Posted 02 Sep 2009 Link to this post

    Hello,

    This is a major issue for us, since most of our scheduled appointments are 30 minutes. We require the SP1 release in order to use some RadDock functions that were not working in 2009 Q2 base. How long will it be before we can get a fix?

    Edit: I have come up with a workaround which involves setting the chkAllDayEvent checkbox to unchecked by default. Apparently it was being checked with the 1/2 hour or less events. I imagine this was caused by that other thread where the person complained about 23.5 hour events getting all day status ;-)

    Jeremy
  5. Boyko Markov
    Admin
    Boyko Markov avatar
    610 posts

    Posted 04 Sep 2009 Link to this post

    Hello Jeremy Murtishaw,

    This issue will be fixed in the next internal build which is expected to be released today. Please do not hesitate to contact us if you need more information.

    All the best,
    Boyko Markov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
Back to Top